Can't install "duration" add-on to "appointments" plugin

When I try to install the "durations" add-on to the "appointments+" plugin, it indicates that I need to "upgrade to Appointments+ to activate". I am a full member and recently took over this site. Why can't I install the add-on? How do I upgrade to appointments+? Please help, I'm a new member and not having a smooth transition into this experience.