Can't install the store themes

I get this when going to Presentation.

Installing Plugin from uploaded file: 145214_framemarket-1.5.1(1).zip

You'll need to activate a BuddyPress-compatible theme to take advantage of all of BuddyPress's features. We've bundled a default theme, but you can always install some other compatible themes or update your existing WordPress theme.

Unpacking the package…

Installing the plugin…

The package could not be installed. No valid plugins were found.

Plugin install failed.

and with the other option:

Installing Plugin from uploaded file: 145214_simplemarket-1.1.1.5.zip

You'll need to activate a BuddyPress-compatible theme to take advantage of all of BuddyPress's features. We've bundled a default theme, but you can always install some other compatible themes or update your existing WordPress theme.

Unpacking the package…

Installing the plugin…

The package could not be installed. No valid plugins were found.

Plugin install failed.

Return to Plugins page

Ideas?
R