Can't Log in to Dashboard Plugin

Hello, I'm attempting to install the DEV Dashboard plugin on a new site that I'm working on and I'm getting a routing error when I click "login" on the form. Is the API down for some reason? I'm being taken to a page at the URL:
https://premium.wpmudev.org/api/dashboard/v1/authenticate
And on the screen I'm getting an error message that states:
{"code":"rest_no_route","message":"No route was found matching the URL and request method","data":{"status":404}}

  • Adam Czajczyk

    Hello Adam,

    I hope you're well today and thank you for your question!

    I'm not aware of our API being down at any time today and trying to replicate this using my own account I wasn't able to. I'd say that this is an issue related to your setup/server but I admin I'm not quite sure where/what to look for yet. Therefore I asked WPMU DEV Dashboard developers for some help on this and will replay to you as soon as I get a response.

    With their help we should be able to pinpoint the reason for the issue and find a solution.

    Please keep an eye on this thread and I'll keep you updated as soon as I get my replay.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello again Adam!

    I was just told that the issue indeed showed up couple of times (it's rare though) and seems to be related to the host, as I expected. I think we should start with basic debugging so please add following lines to your site's "wp-config.php" file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WPMUDEV_API_DEBUG', true );
    define( 'WPMUDEV_API_DEBUG_ALL', true );

    These lines should be added above the "/*That's all, stop editing line...". After you add them, please try logging in again and then access your server via FTP, download the "debug.log" file (it should be located inside the "/wp-content" folder) and share its content with me.

    You may do this either by renaming the file so it had a ".txt" extension and attaching it to your post here or by posting its content in your replay and marking it as "code" (there's a button in post editor " < > " for this).

    Best regards,
    Adam

  • Adam

    Hi Adam,

    Sorry it's taken me so long to respond to this but this website has been a low priority for the past month or so.

    I tried adding the debug info as you suggested but the only thing in my "debug.log" is lines stating that debugging is enabled.

    Today I tried downloading the latest edition of the dashboard plugin and installing that and I'm still having the same issue, strangely however, all my other sites are working just fine (and have continued to do so).

    I opened up the Chrome Dev Tools and preserved the console log and network log to see what's happening, looks like the browser was attempting to navigate to https://premium.wpmudev.org/api/dashboard/v1/authenticate and getting a 404 error at that point. Prior to that it was attempting to connect to http://premium.wpmudev.org/api/dashboard/v1/authenticate (note the HTTP: instead of HTTPS:slight_smile: and getting a 301 redirect error.

    It would seem that the issue is stemming from the fact that the username/password combination was not "forwarded" with the redirect request and that's causing the 404 on the secure authentication page. I've attached a screenshot of what I see when attempting to log in.

  • Adam

    So, out of curiosity I connected to the WPMU Dev authentication page of my Wordpress dashboard via https:// instead of simple http:// and sure-enough, I was able to log-in and authenticate without issue quick and easy as could be.

    Not sure of the source of the issue (could be a Cloudflare problem I suppose?) but it seems like the request needs to be coming from a secure/encrypted connection prior to attempting to authenticate.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.