Cant login

Hi there, I can’t seem to log in, If I try from the Hub it goes to my old logon page at /wp-login.php I have changed it to /mastercontrol. If I go direct I keep getting “ERROR: Sorry, there was an error. Please be sure JavaScript and Cookies are enabled in your browser and try again.” when ever I put in my “Authenticator” number in, I also tried the email option same problem

cheers adrian

  • Adam Czajczyk
    • Support Gorilla

    Hello Adrian Marshall

    I hope you’re well today and thank you for your question!

    The WP Admin link in The Hub is never changed to anything else than the standard WP admin and if you have it changed/masked on site, it will not let you login indeed. However, there’s the new Single Sign On feature available now which handles that.

    You would therefore need to go to your site login (the masked/changed one) directly first and then in WPMU DEV Dashboard plugin on “WPMU DEV -> Settings -> General” page enable “Single Sign-on” option and save settings.

    You can stay logged in or you can logout from your site but after you make that change you should be able to go directly to “WP Admin” area of the site right from The Hub and you’d be automatically logged in – it would work with changed login URL nicely.

    As for the JavaScript and Cookies error that you’re getting if you try to go directly to your site. Please first try accessing it directly again but using either a different browser than usually or using browser’s “Incognito” mode. If that doesn’t help, try using regular mode but clear browser cache and cookies.

    If that still doesn’t let you login to the site (with the same JS and Cookies error) let me know, please, and I’ll need to get a closer look at that to identify reason.

    Kind regards,

    Adam

  • Adrian Marshall
    • New Recruit

    Hi Adam

    Once in I can resolve the Hub login but no luck still getting the error

    I have tried different browsers, private browser and clearing cache I am still getting

    “ERROR: Sorry, there was an error. Please be sure JavaScript and Cookies are enabled in your browser and try again.”

    any Ideas to resolve?

    cheers Adrian

  • Adam Czajczyk
    • Support Gorilla

    Hello Adrian Marshall

    Thank you for your response!

    Just to make sure: that’s related to “media…et.com.au” site of yours, correct?

    Just to test it, I checked your Hub and I can see that it already has the Single Sign-On enabled. When I tried to use it, it worked for me flawlessly there, without any errors (I’m not having any “special privileges” or capabilities so it’s the exact same process as it is for you).

    If you’re accessing from The Hub directly, you shouldn’t also be asked for two-factor auth code.

    However, I understand that you’re still getting that JS/Cookies error even if you click on “WP Admin” for the site from this page, right?

    https://premium.wpmudev.org/hub/my-websites/

    If yes, try this:

    1) access the site via FTP or cPanel “File Manager” tool and edit “wp-config.php” file

    2) you’ll see a code block there similar to this (note: I’ve stripped parts of values to make it more readable):

    define('AUTH_KEY',         'Vqjc...7LTG');
    define('SECURE_AUTH_KEY', '.hlr...Wc');
    define('LOGGED_IN_KEY', '&.D...?L#v');
    define('NONCE_KEY', 'ko...E');
    define('AUTH_SALT', '^yNLn...92x-');
    define('SECURE_AUTH_SALT', 'J-Z...]Rp9');
    define('LOGGED_IN_SALT', '2#o...GE');
    define('NONCE_SALT', '(;ttmnu.....Uwmt');

    3) visit this page

    https://api.wordpress.org/secret-key/1.1/salt/

    copy entire code block from it and use it to replace the one that’s currently in “wp-config.php” file

    4) after saving the file, clear any server-side cache (if there is any) and browser cache and try logging in again.

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.