Cant login to the dashboard

I am trying to log in to the dashboard and this error came

Your server had a problem connecting to WPMU DEV: "cURL error 28: Operation
timed out after 15001 milliseconds with 0 bytes received". Please try again.

If this problem continues, please contact your host with this error message
and ask:

*"Is php on my server properly configured to be able to contact
https://premium.wpmudev.org/api/dashboard/v1/
<https://premium.wpmudev.org/api/dashboard/v1/> with a POST HTTP request
via fsockopen or CURL?"*

I contacted the hosting and this is what they told me
root@aws.goalivemedia.com [public_html]# cat file.php
<?php
if(function_exists('fsockopen')) {

echo "fsockopen function is enabled";

}else {

echo "fsockopen is not enabled";

}
?>
root@aws.goalivemedia.com [public_html]# php file.php
fsockopen function is enabled
root@aws.goatail -n3 error_log
[01-Aug-2017 21:06:25 UTC] [WPMUDEV API Error] 4.2.1 | cURL error 28: Operation timed out after 15001 milliseconds with 0 bytes received ((unknown URL) [500])
[01-Aug-2017 22:06:26 UTC] [WPMUDEV API Error] 4.3.2 | cURL error 28: Operation timed out after 15001 milliseconds with 0 bytes received ((unknown URL) [500])
[01-Aug-2017 23:06:41 UTC] [WPMUDEV API Error] 4.3.2 | cURL error 28: Operation timed out after 15001 milliseconds with 0 bytes received ((unknown URL) [500])
root@aws.goalivemedia.com [public_html]# curl -IL https://premium.wpmudev.org/api/dashboard/v1/
HTTP/1.1 200 OK
Date: Tue, 01 Aug 2017 23:30:58 GMT
Content-Type: application/json; charset=UTF-8
Connection: keep-alive
Set-Cookie: __cfduid=d3363ac04af16ed3da524ebe1279f17261501630257; expires=Wed, 01-Aug-18 23:30:57 GMT; path=/; domain=.wpmudev.org; HttpOnly
X-Robots-Tag: noindex
Link: <https://premium.wpmudev.org/api/>; rel="https://api.w.org/"
X-Content-Type-Options: nosniff
Access-Control-Expose-Headers: X-WP-Total, X-WP-TotalPages
Access-Control-Allow-Headers: Authorization, Content-Type
Allow: GET
Content-Security-Policy: default-src https: data: wss: blob: 'unsafe-eval' 'unsafe-inline'
Strict-Transport-Security: max-age=31536000
X-Content-Type-Options: nosniff
X-XSS-Protection: 1; mode=block
Server: cloudflare-nginx
CF-RAY: 387c96973c8e7906-LAX

The error appears to stem from the URL it's trying to curl being unknown, the server can certainly connect via curl though. I also tried updating the max_execution_time to 300 just to see if this would change anything, it unfortunately did not.

So let me know how to get this resolved and help me use the dashboard and unlock the plugins

  • ingenio

    Hi Adam,

    Thanks for your quick reply!

    I tried a few things:

    - deleted and reinstalled the dashboard plugin, (when it's not installed -> the admin loads fast and no errors, but when installed -> very very slow);

    - re-set the wpmudev API

    - cleared cache on wpengine as well as on cloudflare;

    - tested is on staging and same problem: I'm getting error on wpengine and also getting this message when try to login:

    ****Your server had a problem connecting to WPMU DEV: "cURL error 28: Operation timed out after 15001 milliseconds with 0 bytes received". Please try again.

    If this problem continues, please contact your host with this error message and ask:

    "Is php on my server properly configured to be able to contact https://premium.wpmudev.org/api/dashboard/v1/ with a POST HTTP request via fsockopen or CURL?"*****

    - even if I manage to login, I still get this error on the server:

    [WPMUDEV API Error] 4.3.2 | cURL error 28: Operation timed out after 15001 milliseconds with 0 bytes received ((unknown URL) [500])

    Should I try logging in and giving you access to my staging site?

  • Dimitris

    Hey there ingenio,

    hope you're doing good today and don't mind me jump in here! :slight_smile:

    There were some changes made in our end, so at least latest WPMUDEV Dashboard version (4.3.2) should connect successfully now.
    Have you made to connect with your WPMUDEV credentials until now? Please advise!

    Also, please don't reset your WPMUDEV API key, as long as it isn't being compromised. It doesn't make any change actually for connecting your our services, on the contrary, it initializes lots of background procedures in our end, that may make things even slower for your WPMUDEV Dashboard plugin (at least for some time after resetting).

    If this is continuing for you, please share some more server details of the staging environment. As this is public forum, you should send us your details through our safe contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Dimitris"
    - WordPress admin (login url/username/password)
    - FTP credentials (host/username/password)
    - IP address of your server, to double check that's not blocked from our end (https://wpengine.com/support/find-ip/)
    - link back to this thread for reference
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.