Cant login with "Anyone that visits must first provide this password" setting

This plugin has worked for a long time in my multisite network, but now it does not anymore. The problem is when typing the password my users have set for their blogs, they no longer can see the blog - its just redirected to the login page again.

I cant deactivate all plugins I am afraid, that would be good for testing.

I can see several other people have had same sort of problems, but all threads seams to close without any real solution.

Tried to install http://wordpress.org/extend/plugins/password-protected/screenshots/, and that one worked. All settings i Multisite Privacy works, except that password protection.