Can't make full backups with snapshot

..everytime i try to make a "full backup" with snapshot, i'm getting an error "500". Database only is working. Can you please have a look (maybe it's the server config) and give me a hint or fix it?
Regards Beni

  • Kris Tomczyk

    Hi Beni,

    Hope you are doing good today.

    I logged to your dashboard and I see that your settings on your server are pretty good.
    max_execution_time is set to 300
    memory_limit is set 256M, but you can try to increase that to 512M
    Here you can find an article how to increase that limit:

    When I try to make a snapshot on your site it stuck at media and plugins folders.

    Can you add this to your wp-config.php file:

    /* Snapshot Settings */
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10); //reduce the amount of files processed in 1 go which reduces the server resources required
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600); // will skip files larger than 100Mb (reduce this if need be) skipped files are listed in the logs.
    define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip'); // optional settings are pclzip or ziparchive
    /* End of Snapshot Settings */

    Those lines should be placed above the "/* That's all, stop editing! */" in your wp-config.php file.

    After that try run snapshot again.

    If error 500 will still apper add this one to your wp-config.php file:

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    The line should be placed above the "/* That's all, stop editing! */"

    and run snapshot again.

    Above code will generate in the /wp-content/ folder a debug.log file. Please attach it here or share on dropbox. Thanks to this file we will understand what is causing the error.

    Please answer if that helped.

    Kind Regards,