Can't migrate large sites with Snapshot

Hello,

I'm currently in the process of migrating my Wordpress Network from my old, Apache and PHP5 server (XXX.XXX.XX.244) to a brand new server with the same hardware specs, but now running on Nginx and PHP7 (XXX.XXX.XX.202).

Most of my sites in the Network are fairly small, and I could effortlessly use Wordpress Importer & Exporter to migrate my websites. However, I have to large sites in my network where import/export won't work at all. I've tried with the normal Wordpress Importer (and the unofficial v2 version on Github), but it either crashes or won't progress.

What I've tried:
- Exporting and importing the whole file (posts + media)
- Exporting and importing media only
- Exporting and importing posts only
- Exporting and importing small pieces (month per month)
- Raising the PHP memory limit from 256 MB to 1 GB
- Uploading the mediafiles manually via FTP (but then I'd need to migrate the WP database too, and I unfortunately don't have the knowledge to do that. I'm running on a DigitalOcean VPS using EasyEngine if that helps)

Even after a failed import, some of the posts and mediafiles are accessible on my website. However, images aren't shown and the XML-files itself are present in the media library, which leads to me to believe there's something going wrong with the parsing.

Luckily, I knew Snapshot Pro was able to create backups and migrate my website. I've been using Snapshot Pro, but it refuses to take snapshots for my two larger sites. Planned snapshots or even via the 'run now' feature, the snapshots are never generated. Storage space isn't an issue - tried local and remote. But alas, to no success. I've also never gotten an error message, it just seems to ignore my request to create a snapshot.

Unfortunately I've been stuck for days and don't seem to find a solution to migrate my sites. Any idea what I could do to solve this issue?

Thank you so much for your time and support in advance.

Kind Regards,

  • Nithin

    Hi Jonathan,

    Hope you are doing good today. :slight_smile:

    Did you try enabling debug mode, to check for any error logs? If no, to enable it, open your wp-config.php located in your root directory file, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Please take a backup once you enable it, in case any error occurs it will be saved to a debug.log log file inside the /wp-content/directory. Please attach that file in txt format in your next reply, so that we could give a closer look.

    Also, please enable support access once you attach the log file in your next reply. You can grant access from WPMU DEV > Support > Support Access > Grant Access or see this manual.

    I hope this helps. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Jonathan

    Hello Nithin,

    Thanks for the response! The site I'm trying to migrate is Thalmaray DOT co. Here's what I did:

    On my new server, I tried to import an XML file again. I had one file (two months worth of media) that imported without an issue, however the rest will not import, even when split up. I've attached the textfile for this.

    On my old server, I tried to generate a snapshot of my site I'd like migrated. I clicked 'Run Now', but Snapshot did not run at all. Instead, it just moved the date two days ahead, but scheduled back-ups also do not succeed. I checked my Wordpress directory, but there doesn't seem to be a debug.txt.

    I'll open up support access on both my servers. The old server is the IP that ends on 26.244, while the new server has the following last digits: 17.202.

    Again thank you very much for the assistance and I hope I've provided you with enough information / access to resolve this issue.

    Kind Regards,

    Jonathan

  • Nithin

    Hi Jonathan,

    Hope you are doing good today. :slight_smile:

    Thank you for sharing the debug log files, unfortunately there isn't any error related to snapshot.

    There are couple of things that I could notice, in your old server(26.244):
    1) The memory limit set in snapshot is wrong it should include 1024M or 1G, the letters are important. Due to this the default memory 256M is being picked.

    Changing the value in Snapshot > Settings > Memory Limit would be enough, but your default memory set is 256M, this could be the reason why you have failed export/import even with other tools.

    Defining these in your wp-config.php should increase your memory allocation:

    define( 'WP_MEMORY_LIMIT', '512M' );
    define( 'WP_MAX_MEMORY_LIMIT', '1024M' );

    For more info check this link: http://codex.wordpress.org/Editing_wp-config.php

    2) The max_execution_time is shown as 0. Either the value is not declared, you can check this link on how to declare it. If it's declared, this could be a plugin conflict that switches the value to 0.

    In your new server(17.202), the memory limit set as 256M in Snapshot > Settings > memory limit, please increase this either in snapshot settings, or through wp-config. If you are making changes through wp-config, please make sure to update the memory in snapshot settings too.

    Would recommend that, you please disable all your plugin, and then take a backup to avoid conflict.

    Please let us know how that goes. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Jonathan

    Hi Nithin,

    I've followed your advice, but unfortunately, nothing worked and I can't migrate my large website.

    Then I realized I might be able to restore the database only (since that'd be a lot smaller), and restore mediafiles by copying them via FTP.

    Unfortunately, it doesn't work as well. Exporting the database tables works fine, but it gets stuck importing them again. Getting a 502 Nginx Error, and it's always stuck at 79% for the WP Options table.

    Seems like I'm out of options? :unamused:

    Thanks for the help again.

    Kind Regards,

  • Nithin

    Hi Jonathan,

    Hope you are doing good today. :slight_smile:

    I did give a quick look to your installation, and the setting looks fine. The media files do look very big, would recommend that you split up while taking backups(could see you already doing that), and check where the backup fails, whether the backup fails only for media folders, plugins folders or databases etc. This could lead us to where the issue is coming from.

    Glad to know you have figured a workaround for this, this might be happening because of larger backups. Please let us know if you need any further assistance.

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.