Can't modify anything in Upfront/Spirit

OK so check this one out. I'm using Spirit/Upfront on this site (www.TheGroveEstatesSL.com).

I created a new page in Upfront, called it "Events" with the About template and saved it. However, it puts something else in the browser as follows: https://gyazo.com/f4b2eef3578eb55d7832623bc27c18ed.

When you put that exact url into the address bar, you get the correct page that looks like this ... https://gyazo.com/b5a0e523492a72a77fba3173957830a2.

However, I have no access to that page again if I leave it meaning it's not on my pages list to load for editing.

Further, Events is ALWAYS the blog layout, and looks like this: https://gyazo.com/dc0c1ec826731d8f1cba546863b79f1d. If I load that page, it looks like "Blog template" when i load it, if i change it, and save it, in edit mode i mean, it is still EXACLTY what you see here. it never saves my changes.

Further, I'm trying to create the Events pages for the Events+ plugin, but the shortcodes never work. I tried using the code insertion module and just text and still they don't work.

What's going on here?

I did update all themes and plugins before trying this and I tried working this before updates, always the same.

I'm at a total loss. To wpmudev staff, i'm turning on the access now if you wanted it.

  • Nastia

    Hello Tracy, I hope you are doing well today!

    The Upfront not working with virtual pages and the Events+ plugin partially uses virtual pages. The /event/ will not open with Upfront theme. Our developers know about this and they are looking for a solution.
    This is why you see the blog layout.

    In Upfront for viewing all events, please use the following shortcode:
    [eab_archive]

    Place it on a page and it will show the events. Full library with shortcodes is located in Events > Shortcodes.

    I created a new page in Upfront, called it "Events" with the About template and saved it. However, it puts something else in the browser as follows: https://gyazo.com/f4b2eef3578eb55d7832623bc27c18ed.

    Have you saved the "Events" page? The /edit/ slug means that the Upfront edit mode is enabled. The page URL will be shown properly once you publish it.

    However, I have no access to that page again if I leave it meaning it's not on my pages list to load for editing.

    I can't replicate the same on my sandbox installation. Once I published the page, I was able to open it again.

    I logged in to your site and I notice that the new created page has the same slug as Events virtual page.
    Please navigate to Events > Settings > Events Settings tab and rename Events virtual page to something else. Once you do this the created Events page will open normally.

    Let us know if you require any additional assistance!

    Cheers,
    Nastia

  • Nastia

    Hello tracy, I hope you are doing well today!

    Sorry for my late reply.

    Yes, I created page in Upfront, saved it as Events, and it instead used that edit page # link and the saved Events page looked NOTHING like the page I was working on.

    You need to save the page with another title, or change the events slug in Events > Settings > Events from Events to something else. Once you do this, The "Events" page will show normally.

    I hope this helps!

    Let us know if you require any further information!

    Cheers,
    Nastia