Can't publish or modify posts in wordpress

Hello!

I have a new installation of wordpress single site, and for some reason I can’t publish any new post or change a published one.

I doesn’t give me any error. When I click on publish, it just sends me to the list of all the posts page.

Thanks a lot for the help!

  • Jorge Castro
    • The Incredible Code Injector

    Hello!

    I remember adding a php.ini file to wp-admin folder with this:

    ´upload_max_filesize = 256M

    post_max_size = 256M

    mysql.default_socket = “/kunden/tmp/mysql5.sock”´

    I deleted that file and I can publish again.

    The sad part is that I did that because I need to upload bigger files into my wordpress, my hosting is 1and1, do you have any solution for uploading bigger files?

    Thanks a lot!

  • Sumit Kumar
    • Site Builder, Child of Zeus

    Hey @jorge Castro,

    Thanks for explaining the scratch works that you did by your own.

    I remember adding a php.ini file to wp-admin folder

    PHP.ini is the php configuration settings file and where it is stored on your server is determined by the way your hosting has the server configured. Nothing should be placed or messed-up in wp-admin folder (not recommended by wordpress)!

    The sad part is that I did that because I need to upload bigger files into my wordpress, my hosting is 1and1, do you have any solution for uploading bigger files?

    There’s actually three process of doing that:

    -> One is itself from the server’s php.ini file, but I think you don’t have its access or how to get in there. Contact to your host for this!

    -> Try adding this to the .htaccess file (in your root folder):

    php_value memory_limit 64M

    -> From the wp-config.php file:

    define('WP_MEMORY_LIMIT', '64M');

    Going through any of these steps will help you fix your solution.

    Let us know, if you experience trouble in doing this.

    Regards,

    Sumit

  • Sumit Kumar
    • Site Builder, Child of Zeus

    Hi again, @jorge Castro

    Tough luck on the steps that I provided.

    It seems that you have no other option than to contact your host provider (1and1). Its most likely that the host itself has made restriction, and so changing from config file won’t take any effect with what-so-ever code we write in there.

    Please contact them and explain that if there’s any restriction with your plan and that changing the memory size from config file won’t take any effect.

    Let us know, how they respond you and if they mention you any other way to do that, which we missed to check.

    Regards,

    Sumit

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.