Cant resize images that are previously uploaded

I'm trying to resize previously uploaded images to a max of 1920 in width. I set the option "Resize my full size images" to 1920 x 5000 px and "resmush" all my images, but it does not work...

BTW: If I manually resmush a single image, it works. But that is not an option, because we have a looot of images to resize...

  • Dimitris

    Hello there Max Sandmann,

    hope you're doing good today! :slight_smile:

    I can see the issue in your end and I think that this has to do with the wrong number of attachments reported that need re-compressing (-602!).

    I've already created a report for our Second Level Support team and also pinged Smush's lead developer on this, so they could have a better look at it (at first sight, seems that the "Smush my original full-size images" is causing this wrong calculation).

    Me or another colleague of mine will keep you posted here, as soon as we've got some valuable insights!

    Warm regards,
    Dimitris

  • Nahid

    Hey Max Sandmann !
    Hope you are doing well today!

    As my colleague Dimitris mentioned in his last response, the issue has been reported to the Second Level Support team and the Lead Developer of the Smush plugin. They are currently looking into the issue but unfortunately, we do not have an update addressing it yet. Please note that the response time of the Second Level Support team and Developers might be a bit delayed than that of the General Support team, as they usually go through troubleshooting and fixing very complex issues around the clock. We really appreciate your patience and consideration regarding this. Thanks!

    Kind regards,
    Nahid

  • Lindeni Mahlalela

    Hello Max Sandmann

    I hope you are doing great today. I am sorry for the delayed response from our side.

    I was working on this issue yesterday on your website trying to find a solution but I wasn't able to get a solution yesterday so when I returned today, I can't login with the account you shared with us, I get this:

    ERROR: Invalid username. Lost your password?

    This possibly means the user account was removed from your WordPress admin, as a result I am not able to continue with the troubleshooting. For now, I have noticed that after rechecking the images and clicking "BULK SMUSH" I get a 404 Not Found on certain images, so I have added a plugin called Add From Server which allows to browse the uploads folder to select the images that are not found and add them again to the database. Well, I wasn't able to experiment extensively after that, you may try that plugin and run Bulk Smush again, I believe once the error about images being not found is gone then Smush should be able to work properly. You may remove the Add From Server plugin I added if it is of no use to you.

    I have also noticed in the Media Library that there is a filter that is added to extend the search by filtering the media files according to the page on which they were added. I was not able to find the source for this filter but maybe it has a hand in rewriting the URLs and resulting in images being not found. I am not saying this is a reason, but I think it is worth investigating if you still have this issue.

    If you still need help with this issue, please update the login details so we can access your website again. You may share the updated login details via our secure contact form, on the contact page, choose "I have a different question" then write "Attn: Lindeni Mahlalela" in the Subeject, and include your updated login details in the Message box.

    Please let us know if you need any further assistance and we will be happy to proceed and help in any way possible.

    Have a nice day.
    Lindeni