Can't restore a snapshot (to a local MAMP installation)

Hey all,

Client deleted a page (or a plugin mysteriously deleted a page) a while ago, and client just told me about it. I'm trying to restore from a Snapshot backup to a staging server I just set up on my local machine. I'm doing it this way because I've been told I'm maxing out the number of files available on my hosting plan.

WP 4.0 installed. Snapshot 2.4.3.1 installed, fresh. Segment size set to 5000, to match what's on the live/site of origin. Only active plugins are Snapshot and WPMU Dashboard.

I've downloaded three snapshots: one from today, one from this summer, one from about a year ago. None of them will restore. Each gets stuck in the same place: wp_options.

Here's the complete dump of the error log:

2014-11-10 18:29:32: restore: init
2014-11-10 18:29:37: restore: table: yfm_commentmeta (1/1)
2014-11-10 18:29:37: restore: table: yfm_commentmeta converting URLs from [://www.mikhaylayoga.com] -> [://myoga:8888]
2014-11-10 18:29:37: restore: table: yfm_comments (1/1)
2014-11-10 18:29:37: restore: table: yfm_comments converting URLs from [://www.mikhaylayoga.com] -> [://myoga:8888]
2014-11-10 18:29:38: restore: table: yfm_links (1/1)
2014-11-10 18:29:38: restore: table: yfm_links converting URLs from [://www.mikhaylayoga.com] -> [://myoga:8888]
2014-11-10 18:29:38: restore: table: yfm_options (1/1)
2014-11-10 18:29:38: restore: table: yfm_options converting URLs from [://www.mikhaylayoga.com] -> [://myoga:8888]

I'll happily send along the zip file, so a WPMUster can see if it's refusing to restore anywhere.

I can't count the number of times Snapshot has failed to do what it's supposed to do. While I haven't encountered this particular problem yet, it's frustrating that I'm now trying to sort this out, instead of doing something as simple as retrieving the text and images from a page that was somehow deleted.