Can't restore events from trash

I can’t seem to restore any events from trash. I get an “Access Denied” message. I have tried as superadmin, and I’ve tried in “switch to” mode, as the user who created the event. Same thing happens in both cases.

I’ve enabled support access — hoping someone can help me figure out what’s going on. I’m having some other issues with E+ (which I will post separately about) and in order to troubleshoot, I have to be able to delete and restore events.

Thank you.

  • kalico
    • The Bug Hunter

    One thing that would be helpful to know is what capabilities are required to restore from trash? I have two role/cap plugins active, and perhaps one of them is causing a problem. But I need to know what I’m looking for…. Thx

  • Adam Czajczyk
    • Support Gorilla

    Hello kalico,

    I hope you’re well today and thank you for your question!

    There’s a known “glitch” that our developers are aware of that do not let you restore single events from trash. Hopefully this will be solved in one of the future releases but fortunately it doesn’t happen on all installs and there’s an easy workaround.

    That said, instead of clicking “restore” link for a selected even, check the checkbox on the left of that event, select “Restore” option from the “Bulk actions” drop down list and click “Apply”. I just confirmed that it’s working on your site by restoring one of the events on a main site.

    I hope that helps!

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.