HELP!! Cant see my website on dashboard

I've installed the WPMU DEV Dashboard and Wordpress User Sync plugin, why isn't my website showing up on my dashboard on: https://premium.wpmudev.org/dashboard/my-websites/#?
I have activated/logged on on booth master and sub site??

Master site is: http://www.mydomain.dk and sub is http://www.subpage.mydomain.dk

Is it a problem that sub page is a sub domain on the master site domain?

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Furesø Data ApS,

    Hope you are doing good today :slight_smile:

    You don't need to install WordPress User Sync plugin to add your site in WPMU DEV Hub. Just install WPMU DEV Dashboard plugin and login with user & password that you used to login on wpmudev.org site.

    Here is step by step guide on how to install WPMU DEV Dashboard plugin and login:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/installing-the-wpmu-dev-dashboard-plugin/

    Hope that helps! Feel free to post a reply if you need further assistance.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Furesø Data ApS
    • WPMU DEV Initiate

    I have already done as the guide says. Ive got it to work between two different domain names, but when i try to sync between a domain name and a subdomain to that domain name it want not sync. When i press the sync button nothing happens. What can it be?

    This combi do not work:
    http://www.mydomain.dk (master)
    http://www.sub.mydomain.dk (subsite)

    This combi works:
    http://www.mydomain.dk (master)
    http://www.anotherofmydomains.dk (subsite)

  • Nastia
    • Support Rock Star

    Hello @Furesø Data ApS, I hope you are doing well today!

    Just want to make this clear, the WordPress User Sync plugin synchronize and transfer users across WordPress installations.

    As I see the main issue is, that the WordPress User Sync plugin not synchronizes users. Right?
    The question regarding you not seeing your sites on the dashboard page, is still in power?

    Can you try enabling debug mode, like we explain in the usage guide at the bottom, here: https://premium.wpmudev.org/project/wordpress-user-synchronization/#product-usage

    Copy the contents of the log file created here so we can see where things are going wrong.

    Please advise,

    Cheers,
    Nastia

    • Furesø Data ApS
      • WPMU DEV Initiate

      1. Yes thats correct.

      2. Thats also correct.

      3. I have already done that, but no folder or file was created in the path: /plugins/user-sync/log/error.log

      What to do then?

      It must have something to do with the fact that one of the wp installations is a subdomain to the other wp installations domain.

  • Nastia
    • Support Rock Star

    Hello @Furesø Data ApS, I hope you are doing well today!

    Would you please send to us your credentials from both sites so I could have a look?

    You can send credentials by using our secure contact form https://premium.wpmudev.org/contact/

    Mark to my attention, the subject line should contain only: ATTN: Anastasia

    Please include the following in the email body:
    For Master site:
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)

    For slave site that is not working:
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)

    And please include this as well:
    -link back to this thread for reference
    -any other relevant urls

    Select “I have a different question” for your topic like it's shown in the attached screenshot.

    We'll be waiting for your email!

    Kind Regards,
    Nastia

  • Nastia
    • Support Rock Star

    Hello Furesø Data ApS ,

    Thank you for sending your credentials!

    I've uninstalled the previous settings and set up the Master and Slave site again. After this the users where synchronized. But not all users where copied. I've enabled the WordPress debug, unfortunately there were no errors, and no log files in the /plugins/user-sync/log/error.log from Master site and Slave.

    To make sure this it's not a memory issue, I've increased the memory to 256 by putting the following line in the wp-config:
    define( 'WP_MEMORY_LIMIT', '256M' );

    Would you please disable all other plugins and test again on the both sites? Synchronize users from the Master site. Navigate from your Dashboard to User Sync and click on "Sync all sites now". Once you do, please check the Slave site if all the users where synchronized.

    Thank you for your patience!

    Kind Regards,
    Nastia

      • Panos
        • SLS

        Hello Furesø Data ApS ,

        Have you Debug mode enabled? Perhaps some php notices get sent through ajax responses making them invalid and cause this issue.

        Could you try disabling debug mode? You can do so by changing this line in wp-config.php:
        define('WP_DEBUG', true);
        to
        define('WP_DEBUG', false);
        or to keep debuging more "discrete":

        // Enable WP_DEBUG mode
        define('WP_DEBUG', true);
        
        // Enable Debug logging to the /wp-content/debug.log file
        define('WP_DEBUG_LOG', true);
        
        // Disable display of errors and warnings
        define('WP_DEBUG_DISPLAY', false);

        After that please go to your User sync page and click on the "Uninstall options" and then do a fresh start.

        If this isn't enough, I would also suggest that you manually create an empty log file at /plugins/user-sync/log/error.log

        Please let us know how this works for you :slight_smile:

        Kind regards,
        Panos

  • Furesø Data ApS
    • WPMU DEV Initiate

    Now i have tried all your sugestions. And nothing helps. I got this from the log file finaly (log file on the master site: fuef.dk)

    [2016-04-29 07:24:38][M] 02 - sending request - url=http://markedsplads.fuef.dk/wp-admin/admin-ajax.php?action=user_sync_api;;***
    [2016-04-29 07:24:38][M] 03 - sending request - response=<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>404 Not Found</title>
    </head><body>
    <h1>Not Found</h1>
    <p>The requested URL /wp-admin/admin-ajax.php was not found on this server.</p>
    </body></html>
    ;;***
    [2016-04-29 07:24:38][M] 06 - checking key false;;***
    [2016-04-29 07:42:24][M] 02 - sending request - url=http://markedsplads.fuef.dk/wp-admin/admin-ajax.php?action=user_sync_api;;***
    [2016-04-29 07:42:24][M] 03 - sending request - response=<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>404 Not Found</title>
    </head><body>
    <h1>Not Found</h1>
    <p>The requested URL /wp-admin/admin-ajax.php was not found on this server.</p>
    </body></html>
    ;;***
    [2016-04-29 07:42:24][M] 06 - checking key false;;***
    [2016-04-29 07:43:51][M] 02 - sending request - url=http://markedsplads.fuef.dk/wp-admin/admin-ajax.php?action=user_sync_api;;***
    [2016-04-29 07:43:51][M] 03 - sending request - response=<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>404 Not Found</title>
    </head><body>
    <h1>Not Found</h1>
    <p>The requested URL /wp-admin/admin-ajax.php was not found on this server.</p>
    </body></html>
    ;;***
    [2016-04-29 07:43:51][M] 06 - checking key false;;***

    What else i can tell you guys is that when i do a WP installation on a site with primary domain ex:
    Master: http://fuef.dk
    Slave: http://marked.dk
    ther is no problem.
    THE PROBLEM OCCUR WHEN I USE A SUBDOMAIN!!!!
    In this scenario it fails:
    Master: http://fuef.dk
    Slave: http://subdomain.marked.dk

    I have done a lot of test scenarios and it is vary clear to me that this is the problem. Will you guys please look into that?

  • Nastia
    • Support Rock Star

    Hello Furesø Data ApS

    I hope you are doing well today!

    I have tested the plugin to sync users from site.com to sub.site.com and it is working on my site.

    I connected my subsite as a slave to your master site and all the 309 users were transferred successfully.

    The error that you have posted above shows that the Key of master site is incorrect. Would you please reinstall the slave site options, go to User Sync and click on uninstall options and insert the site and the Secret Key again from the start?

    If after you uninstall option son a slave site and it's still is not working, please send to us the slave site's credentials?
    Send credentials by using our secure contact form https://premium.wpmudev.org/contact/

    Mark to my attention, the subject line should contain only: ATTN: Nastia
    Slave site:
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Let us know how it went!

    Cheers,
    Nastia

    • Furesø Data ApS
      • WPMU DEV Initiate

      Hi Nastia.

      I have already send you that once (cant you find it in your mail) it takes quite a wild to find all those information. Actually. You tried to fix it before. Ofcause i have used the correct key. I dont know the log says i dont.

      MASTER LOG:
      [2016-05-02 09:20:48][M] 02 - sending request - url=http://markedsplads.fuef.dk/wp-admin/admin-ajax.php?action=user_sync_api;;***
      [2016-05-02 09:20:48][M] 03 - sending request - response=<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
      <html><head>
      <title>404 Not Found</title>
      </head><body>
      <h1>Not Found</h1>
      <p>The requested URL /wp-admin/admin-ajax.php was not found on this server.</p>
      </body></html>
      ;;***
      [2016-05-02 09:20:48][M] 06 - checking key false;;***

      SLAVE LOG:
      [2016-05-02 09:20:11][S] 03 - sending request - response=ok;;***
      [2016-05-02 09:20:11][S] 01_2 - sync users for new subsite***
      [2016-05-02 09:20:11][S] 02 - sending request - url=http://www.fuef.dk/wp-admin/admin-ajax.php?action=user_sync_api;;***
      [2016-05-02 09:20:12][S] 03 - sending request - response=ok;;***

      Thanks...

  • Nastia
    • Support Rock Star

    Hello Furesø Data ApS

    Yes, you have sent to us your credentials. I asked because I saw another slave site in the settings. I see that it's now the same with the one that you have sent to us.

    I enabled the wp-debug on your site, and there is a following message:

    WordPress-databasefejl Table '***.wp2_bp_xprofile_fields' doesn't exist for forespørgslen SELECT f.name, d.value
    		FROM
    			wp2_bp_xprofile_fields f
    			JOIN wp2_bp_xprofile_data d ON (d.field_id = f.id)
    		WHERE d.user_id = 1904 fra edit_user, do_action('edit_user_created_user'), call_user_func_array, wp_send_new_user_notifications, wp_new_user_notification, sb_we_get_bp_custom_fields

    Somehow this issue is related to the BudyPress Xprofile Custom Fields Type plugin that you have active on the master site.

    But I do not see any BudyPress Xprofile Custom Fields Type, have you used this plugin for user registration in the past?

    I can't replicate this on my installation, so I have flagged here a second level support to have a closer look. Please note that this issue might require more time to resolve than usual.

    Kind Regards,
    Nastia

  • Panos
    • SLS

    Hi Jonas,

    So you have two wordpress installs and one of them is installed in a subdomain of the first one.

    Could you please confirm if the issue you have here is that the User Sync plugin isn't synchronizing users?

    I am asking this again because I thought it was an issue with the Dashboard plugin but I see it's not installed at the subdomain site.

    Thanks!
    Panos

  • Panos
    • SLS

    Hi Jonas,

    Thanks for the confirmation :slight_smile:

    There is a 404 response message received saying:
    The requested URL /wp-admin/admin-ajax.php was not found on this server.

    I suppose there is some security plugin installed which may block this file. Could you please try temporarily deactivating any plugin that redirects the wp-admin page and give it try?

    Please let us know if it works so we can find a workaround on this :slight_smile:

    Thanks!
    Panos

  • Sajid
    • DEV MAN’s Sidekick

    Hi Furesø Data ApS,
    Hope you are doing good today :slight_smile:

    Did you tried to deactivate the WordFence or any security plugin or module that might be blocking the access to admin-ajax.php file as suggested by Panos above ?

    If no then please try again and let me know how it went.

    Take care and have a nice day :slight_smile:

    Beest Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.