Can't see plugin compatibility from wpmu dev dashboard

The list of plugins that can be installed through the dashboard doesn't seem to be filtered by compatibility - so even though I have BuddyPress installed, it still lists incompatible plugins e.g. Status, Comments Plus, etc.
The compatibility isn't even listed on the info pop up, so you have to go through to wpmudev.org and read the full plugin information page there.