Can't select a plan on pro sites

Hello,

We are running pro sites on our website. We had a user that created an account, but did not proceed with the payment step. She is now a registered user for the network, but not associated with a site.

She is now ready to sign up and logged into her account. When she tries to sign up it says "Sorry, but it appears you are not an administrator for any sites." So we go through the process and try to sign up like a normal user, but it never gives us the option to select a plan it only shows us the "Sorry..." message (or nothing at all). It should display the boxes with the plan options, but instead it displays nothing.

We have granted in case it is needed.

  • Adam Czajczyk

    Hello David,

    I hope you're well today and thank you for your question!

    if a user account exists and is not able to sign up again (most likely due to the fact that the e-mail already is used in WP user database), that user should be able to login and sign-up for a new site being logged in.

    The same Pro Sites checkout page should be visited for this. I suspect though that the "Allow multiple blogs" option on "Network Admin -> Pro Sites -> Settings -> General" page may be disabled on your setup. Is it?

    If so, the simplest workaround in this case would be to enable it temporarily, ask user to login and visit the Pro Sites signup page (being logged in) and then create the site. After that you could then disable the "Allow multiple blogs" option again.

    Would that work for you?

    I also tried to access your site to check if that setting is indeed disabled but it seems that the access is not granted after all. In case above way didn't help, could you please try to grant it again for me?

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.