Can't Set Main Site w/ Global Tables

Hi guys,

I can’t set the Main Site on Membership while it’s Network Activated with Global Tables enabled. Whenever I try to set it via Blog ID in wp-config, it says “you do not have permission to access this page” when I have FULL Super Admin permissions set in the system.

I really need to set my main site in order to create a Member Center for my members. And I don’t want the member center to be on my main site, which is really for visitors.

I know it works, because it worked perfectly on Membership Lite. Can you help me get this fixed?

  • Christian
    • Site Builder, Child of Zeus

    @vaughan,

    I’ve had this issue for a while now, and I’ve asked this question before, but no one has gotten back to me. Can you give me a time frame as to when you’ll have some info on this? And who is the developer for the Membership plugin? Honestly, Membership is the BEST plugin you guys have here at WPMU Dev.

  • Eugene Manuilov
    • Syntax Hero

    Hi @christian

    And who is the developer for the Membership plugin?

    The developer of the Memebrship plugin is me.

    I’ve already tried setting it in wp-config, as I stated above. The problem is it’s not working. How can this be fixed?

    Could you please try the version in attach? It contains a number of fixes one of which fixes the main blog issue. Please let me know how it works on your end.

    Regards,

    Eugene

  • Christian
    • Site Builder, Child of Zeus

    Hi @eugene Manuilov,

    Thanks for getting back to me on this. I tried the new Membership 3.5 Beta 8, and it still won’t allow me to network enable with the main site set in my wp-config file. I can say, that it’s not giving me the same error message (you don not have permission to access this page) when I enable it from the Network Admin. But now it won’t allow me to enable Membership at all with the main site set in my wp-config file.

    You said it contained a number of fixes in addition to the Main Site setting. What are the other issues that this version addresses? I know that you’re working with Paul to fix the issue where Affiliates is counting subscriptions as Paid before the payment is processed. I’m still having that issue as well, and I would like to know what your progress is like on fixing that problem? I can’t start selling memberships until that’s fixed. Any idea as to when that issue will be resolved?

    You’re doing a great job with Membership Eugene. Keep up the good work.

  • Christian
    • Site Builder, Child of Zeus

    Hey @eugene,

    I’m just checking back with you to see if you’re still working on this. Just to recap, with Membership 3.5 Beta 8, it no longer gives me the permissions error when I have the main site set in wp-config, but it will not allow me to enable Membership at all.

    When I was using Membership Lite, this was working smoothly and it was one of the main reasons that I purchased this plugin. The other membership plugins out there don’t allow you to set the main site. This is critical for me, because I need the signups to take place on one of my network subsites where the user’s membership information will be held.

    Can you please help me get this working?

  • Vinod Dalvi
    • WP Unicorn

    Hi @christian

    Extremely sorry that you didn’t get timely reply here, may be my colleague @vaughan has dropped this thread in his feed.

    I have notified the plugin developer and my colleague to reply here.

    Would you mind if we logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just grant us temporary admin access to your site by clicking “Grant Access” button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    Kind Regards,

    Vinod Dalvi

  • Vaughan
    • Support/SLS MockingJay

    Hi @christian,

    Sorry for the delay on this.

    The developer who was working on this has left the company, so this has been dropped.

    I have managed to get the plugin installed globally and network activated, but it does look like there are some big issues with it.

    I can't see any access rules. (screenshot 1)

    But good news (though not really helping due to the other bugs), the global table and mainsite have actually changed as i changed it to main site as id 5. From the repair tables, i can see that it is checking blog id 5.

    I will definitely need to get the new developer @jonathan to look into this quickly to see what's happening.

    Again, sorry for the delays on this, it hasn't been a simple issue to solve unfortunately.

    Thanks

  • Christian
    • Site Builder, Child of Zeus

    Hi guys,

    Thanks for getting back to me on this. @vinod Dalvi, I’ve granted you access to my testsite (teamextremenetwork.com), where I have Membership 3.5.beta.8 network activated. I also have the following defines set in wp-config:

    // MEMBERSHIP PLUGIN - Use a global table system - experimental
    define( 'MEMBERSHIP_GLOBAL_TABLES', true);

    // MEMBERSHIP PLUGIN - Set Main Site
    define( 'MEMBERSHIP_GLOBAL_MAINSITE', 8);

    The Member Center (blog id 8) is the site that I want to be the main site for Membership.

    @vaughan, luckily I haven’t been experiencing the same issue with the access rules. That would be a nightmare.

    About Eugene’s new replacement @jonathan, I would love to get in touch w/ him to help with some development updates on Membership. I’m currently working with @paul on some new Affiliates – Membership Integration features. All of your input would be very useful.

    Thanks again

  • Jonathan
    • The Bug Hunter

    Ok, just wanted to rule that out. I’m not able to enable it either in my test environment. It “appears” to be enabled in Network Admin, but as Vaughan said I can’t set any access levels. I’ve got a few theories I’m going to test out. More soon.

  • Christian
    • Site Builder, Child of Zeus

    @jonathan,

    I think you’ve done it! I’m now able to enable Membership w/ the main site set as blog id 8 in wp-config. The only thing is, I’m not sure if it’s actually registering that site as the main site. I’m still seeing the settings for Membership in the Network Admin, and not in the admin for the Member Center (blog id 8). In Membership Lite, Membership settings would appear on the site that was set. So how exactly can I tell if it’s setting the main site correctly?

    Another thing, once I activated the new Membership 3.5 Beta 9, it completely erased all of my Membership settings. Thankfully, this is the test site and I do have a backup that I can revert back to.

    But thanks for your quick work on this. I appreciate it.

  • Jonathan
    • The Bug Hunter

    Yes, the settings screens are all handled through network admin, but they save to blog id 8 database tables. Which might also be why your settings seem to have gotten erased – when in fact they’re probably still there, but just in a different database table. :slight_smile:

  • Jonathan
    • The Bug Hunter

    Hey @christian,

    Not a problem! :slight_smile: Just an FYI, I’m going to be moving the settings screens back to the site defined MEMBERSHIP_GLOBAL_MAINSITE instead of network admin. It looks like when you’re in saving changes in the network admin some of those settings are saving to the main site (e.g. blog id 1) instead of the site defined in MEMBERSHIP_GLOBAL_MAINSITE.

    So basically it will go back to how it was in Membership Lite. :wink:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.