Can't set multiple URL restictions


I have the URL Restictions add-on enabled.

However it will only let me set a single url to be restricted.

When i try to add more than one URL rule it replaces the previously listed one.

(I want to limit access to /job/ and /expert/ )

Many thanks

  • Adam Czajczyk
    • Support Gorilla

    Hey Chris,

    I hope you're well today and thank you for your question!

    I've accessed your dashboard and I can confirm the issue. I've tried to replicate this on my test install but wasn't able to. I would suspect caching issue but it seems there's no caching plugin installed, unless your hosting provider has implemented some kind of overall cache.

    That said, could you please try the steps below, checking for the issue after each one?

    1. Check with your hosting provider if there's any kind of server-side cache implemented. If there is, try to disable it for a moment.

    2. Revert to a default Twenty Fifteen WordPress theme as the Divi theme that you're currently using on a site is widely known to cause various issues.

    3. Run a plugin conflict test by disabling all the plugins at once except Membership 2 Pro and next enabling them one-by-one, each time checking for the issue.

    4. Download a fresh copy of Membership 2 Pro plugin from here:

    - while being logged in to your account, click on "Download" link instead of "Install" button, save the .zip file to your local storage and unpack it.
    - access your site with FTP and go to this folder on your server:


    - delete /membership/ folder
    - upload the /membership/ folder from unpacked .zip archive to /wp-content/plugins
    - go back to your Network Admin and activate the Membership 2 Pro plugin again.

    Please be sure to take a full backup of your site before running into all these steps.

    Let me know if it helped!


  • chris
    • The Crimson Coder

    Hi Adam,

    I have found the cause of the issue...

    If the setting on /wp-admin/admin.php?page=membership2-settings for...

    "Content Protection
    This setting toggles the content protection on this site."

    .... is switched off then it is only possible to add one url rule.

    As soon as it is activated again additional URL rules can be added.

    Please pass this on to Hoang if you could.

    Best wishes

  • Adam Czajczyk
    • Support Gorilla

    Hey Chris,

    Great troubleshooting! I've noticed that the content protection was off on your site but didn't even though of connecting it to the issue!

    I've checked this on my test site and I can confirm that you're absolutely right. This is obviously a bug as content protection should be fully configurable regardless of whether the protection is enabled or disabled.

    I'm passing this to the developer as a confirmed bug and hopefully he'll be able to fix it as soon as possible.

    Thanks for your information and reporting a bug!


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.