Can't smush some specific image files

After I run the compression option on all images it shows 19 that still need compressing on Hummingbird though also I can't compress them individually (Smush)
And if I hit recheck images it says they are all done.

If I go to my library and search for 250 braids, I don't see an option to smush. Just add watermark, restore, and smush stats.

  • Nithin

    Hi Nathan Swafford,

    Hope you are doing good today. :slight_smile:

    I checked your website, and its seems like a small glitch, could you please disable the Super-smush my images option, under Media > WP Smush, and then install the regenerate thumbnails plugin, to regenerate the images.: https://wordpress.org/plugins/regenerate-thumbnails/

    Once you regenerate the particular images which is having issue, please re smush it. Please do make sure that the Super Smush my images option is disabled for these images when smushing.

    Please let us know how that goes, so that we could give a closer look. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Nathan Swafford,

    Hope you are doing good today. :slight_smile:

    I gave a quick test in your system, and I could see the result to be same. I have pinged the developer, and have asked to give a look regarding this. Please do note that developers work round the clock, and have a slow response time. Either myself, or the developer will keep you updated. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • NateS

    I completely deleted one of the images that smush was having an issue with 250braids.jpg and tried uploading it again. I received the following error.

    Warning: Error while sending QUERY packet. PID=7586 in .../wp-includes/wp-db.php on line 1811
    643

    After deactivating Hummingbird I was able to upload it.

    Edit* - Just went into media and saw several versions of 250braids.jpg. So it uploaded even though it errored out. Maybe that has something to do with it.

  • Nithin

    Hi Nathan Swafford,

    Hope you are doing good today. :slight_smile:

    I checked further, and if I'm not mistaken, all the images shown in Google Page speed are related to the Featured Products slider. This is because the images are too large from where it's being displayed. The issue seems related to the slider, and the only solution is to resize the images, according to the themes content width, that would be 180*180px.

    On further going through your website, resizing won't work in your slider, because the slider is currently calling the featured image of each product, so resizing the image would make featured image(500*500px) to resize to 180*180.

    I couldn't find such settings, but does your slider have any option to include, a thumbnail image instead of calling the featured image.? If yes, this should resolve it.

    Google Page Speed does pick such images as not optimized, and the only solution is to make the images the right size, that would be 180*180. It's also one of the issues, which is harder to fix in Page Speed. I Could only suggest, If possible, to try other slider plugins from the plugin directory, and check whether it helps:
    https://wordpress.org/plugins/search.php?q=carousel+slider

    Warning: Error while sending QUERY packet. PID=7586 in .../wp-includes/wp-db.php on line 1811
    643

    I tried to upload a new image, and I wasn't able to replicate this in your system, nor in mine. Do you still get this error? Please let us know more about this, so that we could help troubleshoot it.

    I hope this helps. Please let us know if you still need any further help. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Nathan Swafford,

    Hope you are doing good today. :slight_smile:

    Sorry for creating any confusion, I think there is a misunderstanding, as mentioned before, I meant the Featured Products carousel slider. If you check the source code, it's a fusion carousel slider. You'll have to make sure these images are resized to 180*180px, in order to pass the optimization in Google Page Speed.

    EDIT: Image Screenshot, posted below: https://premium.wpmudev.org/forums/topic/cant-smush-some-specific-image-files#post-1105028

    With the current slider, resizing is not possible, if you resize, the featured image in your post will also be 180*180, instead of 500*500.

    Is it possible to switch that slider to Layer slider? If yes, could you please set it to Layer Slider(or any other plugin), so that I could check, and see whether we could correct this issue. Please advise if I am missing anything.

    If you didn't find any change when switching to a new slider, most probably it's due to minified JS, and CSS file in the Hummingbird plugin. You could temporarily disable the browser cache, and minification in the Hummingbird plugin, in order to check whether the changes are taking place.

    You can find the images listed in Hummingbird, under Hummingbird > Performance Report > Optimize images. All the images are related to the Featured Products carousel slider.

    I hope this helps. Please let us know if you still have any doubts, and let us know how that goes, so that I could give a closer look. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.