Can't update all plugins – error Update Failed: -1

I cannot update any of my plugin. If i go to plugin > installed plugin and click update on any plugin, it will show error “Update Failed: -1”. If i go to WPMU Dev plugin and click update, nothing happen.

We tried plugin conflict and removing errors found in debug.log (debug log available on live chat with Kasia)

Increasing memory limits didn’t change anything. Access will be open.

  • Ken Kimbrell
    • The Crimson Coder

    Hello Abdul-

    I have looked into your problem, and it appears I will need to gain additional login credentials in order to further access the problem. You can send me the credentials through our private form:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Please visit our private Contact page and complete the form with the following information:

    Subject: “Attn: Ken Kimbrell”

    In the Message box, please provide the following:

    – link back to this thread for reference

    – any other relevant urls

    – Admin login:

    Admin username

    Admin password

    Login url

    – Hosting Control Panel Login

    Admin username

    Admin password

    Login url

    – FTP credentials

    host

    username

    password

    (and port if required)


    Take Care,

    Ken – WPMU DEV Support

  • Ken Kimbrell
    • The Crimson Coder

    Hello Abdul, I am seeing a lot of errors associated with memory allocation. I see you have had this problem in the past as you have increased the WP memory to 512M. You do seem to have a lot of plugins, and this can cause similar issues, the inability to add more plugins, or in some cases activate old ones or even update them if the plugin had a large update. I was actually able to update akismet, which is an extremely light plugin. Before I troubleshoot any further I ask that you remove any plugins you are not actively using completely and further prioritize the core plugins needed to generate the functionality you are after and other activated plugins that you could deactivate and remove. Once you do some manicuring of your plugins, I will look into it more for you.

    Let me know how I can help!

    Take Care,

    Ken – WPMU DEV Support

  • Ken Kimbrell
    • The Crimson Coder

    Hello Abdul-

    You still have 70+ plugins. That makes it very difficult to troubleshoot any type of plugin conflict without taking your site down. You may want to deactivate all plugins at once, then activate just one plugin and try to update to rule out plugin conflict.

    Let us know how we can help!

    Take Care,

    Ken – WPMU DEV Support

  • Abdul Bari
    • Site Builder, Child of Zeus

    I already deactivate all plugin and try to update all the plugin but still fail. I tried to update in random order also fail. No plugin want to update at all. I cannot deactivate more plugin as the plugin are used by various website. If I take it down then the website will be down or the configuration will do haywire. It used to able to update all plugin without any problem until recently. I do not know what have changed that breaks it.

  • Abdul Bari
    • Site Builder, Child of Zeus

    I found out something. see attachment.

    For example, if i click on Update Now on the yellow highlighted link

    “There is a new version of Akismet Anti-Spam available. View version 3.3.1 details or update now.”

    then i will get “Update Failed: -1”

    but if i click on Update now on the other update link, i can update my plugin. It will direct me to a update plugin page and it can update.

    So now I am wondering, what cause the yellow highlighted link update to cause error. not all plugin i can do something like this. mostly will show update now on yellow highlighted link. therefore i still cannot update most of my plugin.

  • Ken Kimbrell
    • The Crimson Coder

    Hello Abdul-

    I am sorry to hear that the problem has still not been resolved. Have you considered downloading a fresh install of wordpress and overwriting all wordpress files VIA FTP transfer? Then you can see if the problem resides within the core wordpress files. Additionally you can consider re-downloading fresh copies of your plugins from the repository to ensure no malicious codes were injected into one of your plugins. Of course you would want to make a back up before trying this and so that you can reconfigure any custom pages, e.g wp-config.php, ini.php, etc.

    Let me know how I can help.

    Take Care,

    Ken – WPMU DEV Support

  • Ken Kimbrell
    • The Crimson Coder

    Hello Abdul-

    Have you tried to download a fresh install of wordpress and then overwrite the wordpress files VIA FTP to make sure there is no issues with missing or corrupted core wordpress files?

    Sorry to hear you are still experiencing problems with not being able to update your plugins. I am happy to know you discovered a workaround, while you still keep looking into the root cause of the problem.

    Let us know how we can help!

    Take Care,

    Ken – WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.