Can't update network (access denied)


I have a multisite installation that it’s driving me crazy. First of all, I can’t manage to update the network, when I click update network, I get a list of all the subdomains in my multisite (4 wordpress installations) and below them “access denied” which is weird because I am the only super-admin in the entire network.

Secondly I think I might have a serious problem with the cron jobs. Snapshot won’t do any backup, only the manual ones, the scheduled posts won’t be published and I tried everything, I tried to do the cron through plesk, disable wp_cron etc… and nothing worked, I even installed WP Missed Schedule which worked right after the installation, it published all my missed scheduled posts, but the next scheduled posts keeps missing them, as well as the snapshot backups, which is set once a week.

I tried disabling all the plugins, disabling Wordfence, Wp Rocket…and nothing…

I would be extremely thankful if some of you could help me with his issue, because I’m about to give up a do everything manually….

Thank you!