Can't Update Plugin because of WPMU Dashboard Plugin

WPMU Dev plugin breaks my site. I am with WP Engine Hosting and if I keep it activated I can't access my dashboard until hosting deactivates it for me. Now I need to update membership2 plugin but it won't let me because WPMU Dev plugin is deactivated. Help....

  • Sajid
    • DEV MAN’s Sidekick

    Hi Paul,

    Hope you are doing good today :slight_smile:

    I am sorry for inconvenience! We are aware of this issue and working on it.

    Would you mind explaining the issue with details ? I mean if you see any error message then please post it here.

    Meanwhile, I have contacted the developer and he says the Dashboard latest version is working on WP engine hosting on his development site and could update Membership 2 plugin as well. Please follow the steps below and let us know how it goes.

    1. Deactivate and delete WPMU DEV Dashboard plugin.

    2. Download the latest version from project page.

    3. Install and activate from Admin > Plugins > Add New > Upload.

    4. Now login and update Membership 2 plugin from Admin > WPMU DEV > Plugins.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Cheers, Sajid

  • Paul
    • Design Lord, Child of Thor

    I followed your instructions exactly and the same thing happened. The plugin uploaded and asked me to activate. I did and got a 502 error and cannot get into wp-admin. I had to restore to previous checkpoint to get back in.

  • Sajid
    • DEV MAN’s Sidekick

    Hi Paul,

    Hope you are doing good today :slight_smile:

    I am sorry to hear its still did not worked for you and thanks for providing the error message information. I will pass-on this information to developer and get back to you as soon as possible.

    Meanwhile, please update the Membership 2 plugin manually by following below steps:

    1. Backup your site and deactivate Membership 2 plugin.

    2. Delete membership 2 plugin.

    3. Download the latest version of Membership 2 plugin from project page.

    4. Now upload from Plugins > Add New > Upload.

    5. Activate!

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi Paul,

    Hope you are doing good today :slight_smile:

    I have heard back from the developer and he said while installing the plugin on couple of WPEngine hosted sites he did not get 502 error message. However there are API issue to update the plugin being reported.

    So this error is sporadic. Is it possible for you to enable WPMU DEV debugging post back debug data here ? If yes then please add following line of code in wp-config.php file of your WordPress installation before the line that says stop editing.

    define('WPMUDEV_API_DEBUG', true);
    define('WP_DEBUG_LOG', true);

    You will find debug data on following location:
    wp-content/debug.log

    This debug data will be helpful to determine the cause and fix this issue quickly.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi Paul,

    Hope you are doing good today :slight_smile:

    That would be great if you can send FTP and WordPress login details of your staging site so I can make those changes and get the debug log.

    You can send credentials by using our secure contact form https://premium.wpmudev.org/contact/

    - Mark to my attention, the subject line should contain only: ATTN: Sajid Javed
    -WordPress admin username
    -WordPress admin password
    - login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select “I have a different question” for your topic.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.