Cant update the latest version of plugin from wpMudev

Cant update the latest version of plugin from wpMudev, always saying you have the latest version.