Can't update to latest version

I have version 1.0.9 of Appointments+ installed. On my dashboard, there is the latest version, 1.1.0.1, to be updated to. I was able to download it, but unable to update it; the process failed.
What is the best way to update this? My dashboard does not seem to have the ability to auto-update this plugin.
Thanks in advance for any assistance.

James