Cant update WP core

First time I've encountered this problem. Stuck! The Wordpress is saying 4.96 is installed. And that it's the latest version of Wordpress. No way to upgrade. Now I know 5.0 is available. I've been upgrading all my other sites.

Figured I'll try the manual way. I downloaded 5.0 and extracted it in the root directory. But the admin is still showing 4.9. I have Sucuri Firewall running and a caching plugin. I cleared cache on all multiple times and tried on different browsers. Still stuck at 4.9

How can I upgrade and/or have it show the correct version?

  • Nithin
    • Support Wizard

    Hi gediweb,

    Could I know how was the manual update done? You replaced, the /wp-includes, and /wp-admin folder with the latest update, right?

    Even after manual update, it's still showing the old version, then that's an odd issue. Maybe there is still cache enabled in the server side? Cache like Object cache, will cache the dashboard, so either you are still seeing a cached version of the dashboard, or something else causing the issue.

    Could you please check whether you could update via dashboard, once the plugins are deactivated? Also, check whether the following article helps with manual update:
    https://www.wordfence.com/learn/how-to-manually-upgrade-wordpress-themes-and-plugins/

    If you still have issue even after following the above article, please enable support access to your site, so that we could have a better idea.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.