can't upgrade wpmu dashboard to 3.4.5

I get this error message when trying to upgrade the WMPU dashboard:

Updating Plugin WPMU DEV Dashboard (1/1)
Downloading update from https://premium.wpmudev.org/wdp-un.php?action=download&key=3946c9bd59e0e7ecd59b82b0ca37693e970738ff&pid=119…
Unpacking the update…
Installing the latest version…
Removing the old version of the plugin…
Plugin update failed.
An error occurred while updating WPMU DEV Dashboard: Could not remove the old plugin.

Any help would be appreciated.