Can't upload images

Hi there, I'm having a problem uploading images: Real Homes>New Property>Add images on the upload form
I haven't made any changes to the site recently but am having problems with Gzip which hostgator are looking at. I would apprecite any help in getting this working, this is a live real estate website for 2 separate offices and we have new properties to upload. Thanks for your help. Dave

PS I have given access to the site through My Hub

  • Adam Czajczyk

    Hi Dave,

    I hope you're well today and thank you for your question!

    I checked the site and I could see the issue. However, it's not related to that "real estate" part of the site only. I tried to upload a small image to Media Library directly and also couldn't do it and that suggests that the problem is "site wide".

    I'd actually start with a very simple check: access your server management panel (cPanel most likely) and check if you didn't reach the quota (disk space/storage limit). That's very common cause of such issues and also very often overlooked :slight_smile: Just make sure about it.

    If that's the case, you might need to find a way to regain some space (e.g. by removing some unnecessary files from server or some old/unnecessary/unused images from site etc).

    If that's not a case, I would suggest reaching out to your host to ask them if/what changes did they make to the server/site while attempting to fix the gzip issue as this might be related.

    Then, next step would be to run a full conflict test:
    - disable all plugins and switch to Twenty Seventeen theme
    - check if you can add image to media library
    - if yes, switch to the current theme and check again;
    - if that still works, enable plugins back one by one each time checking for the issue until it happens again.

    This way you'd identify if a theme or some plugin (the last one enabled before it happens again) is the culprit.

    If the test doesn't show anything as well, we'll need to check WP debugging outcome. To do this, please:

    - add following lines to the "wp-config.php" file of your iste

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    Make sure that these lines are above /* That's all, stop editing */ line

    - then try uploading image a couple of times again
    - then look into the /wp-content/ folder on your server and there should be a file called "debug.log"
    - download that file, rename it to "debug.txt" and attach to you response here.

    Please follow these steps and get back to me here and hopefully this will let us solve the issue.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.