Can't upload jpeg files on subsites

I was in a chat with Ken and accidently closed my browser. Sorry Ken!

Domain: illuminero.com

Anyhoo, I can upload .png files (and maybe other media?) to subsites, but not jpg files. The files upload but show up as broken links.

I'm able to upload jpg files to my primary site.

I disabled all plugins and themes to try to troubleshoot the problem. No luck.
My .htaccess file:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
# add a trailing slash to /wp-admin
RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
RewriteRule ^(.*\.php)$ $1 [L]
RewriteRule . index.php [L]

</IfModule>
# END WordPress

My wp-config file includes the following:
define('WP_DEBUG', false);
define( 'WP_ALLOW_MULTISITE', true );
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', true);
define('DOMAIN_CURRENT_SITE', 'illuminero.com');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);
define( 'SUNRISE', 'on' );

  • Nithin

    Hi Lane,

    I checked your subsite, and I could see the issue in your subsite. Just to be sure are you using Wild card SSL? I could see SSL is only active in mainsite, it doesn't seem to work for the rest of your subsite. To have a better understanding of this issue, could you please enable debug mode, so that we could have a better idea.

    To enable debug mode, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    After making the above changes, please try to replicate the issue by uploading jpg images. The related errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    Please let us know how that goes, have a nice day.

    Kind Regards,
    Nithin

  • Lane

    Nithin,

    Thank you for taking the time to help.

    I made the changes in wp-config, but it broke the site, giving me a HTML-500 error. So I changed it back.

    Regarding the lack of a wildcard SSL, dealing with that is on my list of things-to-do, but I haven't resolved it yet.

    Illuminero is under a Let's Encrypt SSL, which doesn't do wildcard certs, to my understanding. I just a couple days ago converted the domain to multisite.

  • Kasia Swiderska

    Hello Lane,

    have you added those exact lines

    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    before the line /* That's all, stop editing! Happy blogging. */ ?
    They need to look exactly like that with all the semicolons. If you are not sure how to add those we can do this for you. If you want that could you please send in the following via our secure contact form https://premium.wpmudev.org/contact/ :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm here that you send those credentials

    kind regards,
    Kasia

  • Nithin

    Hi Lane,

    So I got fed up and restored my backup copy of my single-site installation of Wordpress.

    I checked the shared debug log file, and it doesn't give any clue regarding what could have gone wrong. Sorry to know that you had to switch back to a single site installation.

    It seems like the support access isn't enabled, so I couldn't check the site. Does switching to a single site resolve this issue? Is there anything else we should be checking related to this issue?

    Please do let us know if you still need any further assistance, and enable support access if you want us to give a closer look. Have a nice day ahead.

    Best Regards,
    Nithin

  • Lane

    Hi Nithin,

    I have a number of multisites I was wanting to create as a multisite network under illuminero.com. The combination of having issues with illuminero.com and seeing that there maybe aren't many people doing networks of multisite networks under one domain, I decided to instead have multiple multisites instead. I think that'll be a better solution for me since I like to sift through other people's past issues to solve my own. More material to work with.

    Everything is good now. Marking as resolved.