Cant upload or change Slider

Hi when I try to upload. I get HTTP error, if I use browser uploader it does upload.

From pages it doesnt work either. I have checked permissions and they seem fine, also I have disabled Addons.

If I use the Layerslider. Icant upload or if I select the image url I get this error attached.

What is the problem please?

thanks

  • Dimitris

    Hey there Shaun,

    hope you're doing good and thanks for reaching us! :slight_smile:

    This could be happening due to different reasons.

    First of all, let's start with basic troubleshooting steps, which include to upgrade all themes and plugins you're using, as well as core WP files, if not already in latest version 4.8.
    After that, you should also proceed with a basic conflict test between your plugins and themes, just in case some latest update of any of these, messed this up! The concept here is to deactivate all plugins, activate a default theme like TwentySeventeen, clear/purge all caches and try image uploading again. If this resolves the issue, activate them back one-by-one until you get this issue once more, thus the conflicted combination. Here's a nice flow chart image that can help you with this: https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif
    Reference: https://premium.wpmudev.org/docs/getting-started/getting-support/

    Other things that you should also consider are:

    1. Folders and files permissions and user:group assigned to these. All directories should be 755 or 750. All files should be 644 or 640. As for the proper user:group assigned to these, you should contact your hosting provider about it, as this may vary in every server setup. Default Apache servers are using www-data:www-data, but this isn't the case in all setups.
    Reference: https://codex.wordpress.org/Changing_File_Permissions#Permission_Scheme_for_WordPress

    2. Check that the uploads folder in use is the correct/desired one.
    https://wordpress.stackexchange.com/a/161396

    If this continues to your end after all these steps, please grant us with support access to have a better look. Here's how to do so, if not know already.
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4
    Let us know here in your next reply that access has been granted (and the domain name in question) as we don't get any notifications about it.

    Finally, activate WP_DEBUG just in case there's any piece of info that could be useful to us. Simply access your server via FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and try to replicate the errors you've mentioned above.
    By doing so, a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply. If size of text file exceeds the 5MB limit of our blog, please use a service like Dropbox and post the shareable link instead.
    Ref: https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    Warm regards,
    Dimitris