Captcha not showing up

Hi. The Captcha in the contact form isn't showing up. I'm getting a missing image icon instead (see screen capture). The image source is for a php file instead of an image? I upgraded to 2.3.2.3 since a different thread issue seemed to be fixed by that. No luck though.

<div class="editfield">
<label for="cf_random_value">Security image (required)</label>
<img class="captcha" src="http://caspercitizen.com/wp-content/plugins/classifieds/ui-front/general/cf-captcha-image.php" />
<input type="text" id="cf_random_value" name ="cf_random_value" value="" size="8" />
<p class="description">Enter the characters from the image.</p>
</div>
  • aecnu

    Greetings russell_weller,

    Sorry to see that you are having an issue with your WordPress installation and the Classifieds plugin.

    Unfortunately I am unable to replicate the issue as shown here on my production server: http://classifieds.aecnuwpmu.us/classifieds/

    Now it is time to go into full blown trouble shooting mode because it appears there may be some conflict there and one way to find out conclusively.

    Standard plugin trouble shooting protocol - first to switch to the Twenty Eleven theme just long enough to check for the problem - if the problem still exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting.

    You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    Cheers, Joe

  • Russell Weller

    Thanks for getting back so fast Joe! Sorry, I should have been more clear. I had already tried going to twenty twelve (and just tried twenty eleven) with all plugins disabled and still had the same problem because of a previous issue I had, which I'll detail below.

    After thinking about it a bit more, I wonder if I maybe don't have the modules necessary on my apache server to run the captcha script? What does it need?

    On a not-really-related note, I had theme issues earlier with the "Create a Classified" form because the headline box for the form used the ID title, which seems like it's a bit generic for use in a plugin. I changed it to cf-title, and everything there seems to be working fine now.

    Thanks!
    Russell

  • aecnu

    Greetings russell_weller,

    Thank you for your kindness and for letting us know what is going on there.

    You are spot on that it is localized issue and now wondering if you have resolved the matter on your particular WordPress installation and hosting configuration?

    I do not know of any packages that are required for captcha, possibly the GD library?

    Not that I read that anywhere but servers and networks are my native profession and that was the first thing that came to mind.

    Please let me know how it is going and in any event have a GREAT upcoming weekend!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.