category image not updating (pulling from other category)

Hi, we've created several categories here:

http://www.nbw.ca

If you look at this category:

http://www.nbw.ca/store/products/category/body-lotion/

The problem is that it is pulling the image from THIS category:

http://www.nbw.ca/store/products/category/eczema-care/

We have the correct image set in the control panel for the first category, it is not showing up.

Even after we delete the category image entirely from the first category, it still displays the second category's image.

Same problem with:

http://www.nbw.ca/store/products/category/bar-soap/

  • thirteen
    • Flash Drive

    I think this got fixed before you looked at it.

    What we figured out was happening was the following:

    We had some products which belonged to two categories (the eczema one and say, body lotion), when we ticked the checkboxes for both categories, the product category image from eczema would appear on the body lotion page.

    As soon as we took the products out of the eczema category, this went away.

    So we ended up created a second SKU for each product, one for each category, but I don't think this is intended behaviour?

  • aecnu
    • WP Unicorn

    Greetings thirteen,

    Thank you for your feedback and for posting the solution as well, it is greatly appreciated.

    So we ended up created a second SKU for each product, one for each category, but I don't think this is intended behaviour?

    I agree that this is probably not the intended behavior though I admit your fix is certainly workable for those who are also experiencing this phenomenon.

    Some rep points sent you way.

    Thank you for being a WPMU Dev Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.