category links no longer working

I am in need of some help here.
I am working hard on a test site as I attempt to move my current site over to the WP and BP platform.

I have a single site and a multi site setup as I test both options.

On the MU site all my category links no longer work. I actually can't confirm if they ever worked as I hadn't messed much with navigation and content on this site till the last week or so. I had let it go till now and upon setting up my navigation menu with some of the links discovered the issue again.

I have deactivated all plug ins and still go the issue.
I have tried changing the permalinks and get the same issue.
Actually I probably need to set that back to default now that BP is also deactivated. I will review that and reply with my results.

I have read a few things on WP.org which took me around and around to nowhere. I am hoping the smart folks here can help me find a solution.

Thanks.

  • DavidM

    Hello rickdlewis,

    I haven't come across that one myself and I'm venturing to guess the problem precedes this plugin, but perhaps it would work for you. There's a link to a revised version of the Top Level Categories plugin sitting somewhat near the bottom of this page. Perhaps it might fix the issue?

    http://wordpress.org/support/topic/top-level-categories-broken-on-wp-31

    Cheers,
    David

  • Rick Lewis

    plug in did not work.

    So far the only thing that allowed my links to work was deleting the htaccess file and putting back to default.

    Can not use any other options which for sure I would want to use a custom option as the default links look like crap.

    I have no clue about all this rewriting and such so if someone has an answer to getting my category links working that would be super.

    thanks.

  • Rick Lewis

    This is still not resolved for me.

    Here is an added bonus I guess.
    When I just clicked on a link to visit a plugins website it put the url at the end of my url and of course game me an access denied page at my site.

    http://test.crosseyedgamer.com/wp-admin/www.numediastudio.com

    What would cause that to happen?

    NOTE: I have erased the htaccess file multiple times and tried to regenerate it or manually add a new one. I also have BuddyPress so if I go back to default permalinks to get everything else working, BP doesn't work.

    That tells me it has to be something with the permalinks and/or htaccess. no?

    Hope someone can help.
    Thanks.

    EDIT - below is my htaccess file .. note I had this issue prior to adding the other entries.

    I just removed the old WP entry and put in what is there now based on another site which works using the custom permalinks as /%postname%/

    Still got nothing for my category links but the buddypress links work fine.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    # BEGIN bbPress

    Options -MultiViews

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /forum/

    RewriteRule ^page/([0-9]+)/?$ /forum/index.php?page=$1 [L,QSA]
    RewriteRule ^forum/([^/]+)/page/([0-9]+)/?$ /forum/forum.php?id=$1&page=$2 [L,QSA]
    RewriteRule ^forum/([^/]+)/?$ /forum/forum.php?id=$1 [L,QSA]
    RewriteRule ^forum/?$ /forum/ [R=302,L,QSA]
    RewriteRule ^topic/([^/]+)/page/([0-9]+)/?$ /forum/topic.php?id=$1&page=$2 [L,QSA]
    RewriteRule ^topic/([^/]+)/?$ /forum/topic.php?id=$1 [L,QSA]
    RewriteRule ^topic/?$ /forum/ [R=302,L,QSA]
    RewriteRule ^tags/([^/]+)/page/([0-9]+)/?$ /forum/tags.php?tag=$1&page=$2 [L,QSA]
    RewriteRule ^tags/([^/]+)/?$ /forum/tags.php?tag=$1 [L,QSA]
    RewriteRule ^tags/?$ /forum/tags.php [L,QSA]
    RewriteRule ^profile/([^/]+)/page/([0-9]+)/?$ /forum/profile.php?id=$1&page=$2 [L,QSA]
    RewriteRule ^profile/([^/]+)/([^/]+)/?$ /forum/profile.php?id=$1&tab=$2 [L,QSA]
    RewriteRule ^profile/([^/]+)/([^/]+)/page/([0-9]+)/?$ /forum/profile.php?id=$1&tab=$2&page=$3 [L,QSA]
    RewriteRule ^profile/([^/]+)/?$ /forum/profile.php?id=$1 [L,QSA]
    RewriteRule ^profile/?$ /forum/profile.php [L,QSA]
    RewriteRule ^view/([^/]+)/page/([0-9]+)/?$ /forum/view.php?view=$1&page=$2 [L,QSA]
    RewriteRule ^view/([^/]+)/?$ /forum/view.php?view=$1 [L,QSA]
    RewriteRule ^rss/?$ /forum/rss.php [L,QSA]
    RewriteRule ^rss/topics/?$ /forum/rss.php?topics=1 [L,QSA]
    RewriteRule ^rss/forum/([^/]+)/?$ /forum/rss.php?forum=$1 [L,QSA]
    RewriteRule ^rss/forum/([^/]+)/topics/?$ /forum/rss.php?forum=$1&topics=1 [L,QSA]
    RewriteRule ^rss/topic/([^/]+)/?$ /forum/rss.php?topic=$1 [L,QSA]
    RewriteRule ^rss/tags/([^/]+)/?$ /forum/rss.php?tag=$1 [L,QSA]
    RewriteRule ^rss/tags/([^/]+)/topics/?$ /forum/rss.php?tag=$1&topics=1 [L,QSA]
    RewriteRule ^rss/profile/([^/]+)/?$ /forum/rss.php?profile=$1 [L,QSA]
    RewriteRule ^rss/view/([^/]+)/?$ /forum/rss.php?view=$1 [L,QSA]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^.*$ /forum/index.php [L]
    </IfModule>

    # END bbPress

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.