Category pages limited to 5 products when paginated

When Store Settings > Presentation > Product List Settings is set to "Yes" Paginate, the category pages are limited to 5 products regardless of the number of products set per page. The base Product page works fine and displays the correct number. It is when you browse by category when the paginate setting is activated that I'm getting 5 products per page.

Not sure why this is the case, but I'm wondering if this is because of how WordPress handles Archive pages (isn't that what Category pages really are). If that's the case, is there a code snippet I can drop into functions.php to get some control of this?

  • Kimberly
    • Champion of Loops

    Hi there!

    You can get around using the Products Shortcode and specifying your category and pagination there :slight_smile:

    Unless you are really wanting it to show by default on the category page. Have you checked your site settings to see what the default # of posts are? Products are custom post types, so perhaps it is reading from there?

    Best,

    Kimberly

  • Saunt Valerian
    • The Bug Hunter

    I was hoping to avoid the need for shortcodes by building the navigation of the site around the dynamic MP pages (since they are there, it just seems an efficient way of doing it). Guess that's not going to work then.

    I did check the default post count settings and that had nothing to do with it. Didn't seem to make a difference at all.

  • Saunt Valerian
    • The Bug Hunter

    Hmm, shortcodes is not the answer and it was an interesting result. When pagination is set to true in the shortcode, the 5 product limitation appears again (even worse though, it does so without the Next Page link - though remember that pagination didn't work right in shortcodes, but I though Aaron fixed that...?). When I remove the pagination definition it show all products fine.

    I've gone through the theme configuration pages (it's recently updated theme from Elegant Themes) and don't see anything that could be conflicting.

  • Saunt Valerian
    • The Bug Hunter

    Found it!

    Good thing too, I was beginning to think that I was going to have to put together some template files. It was the theme.

    Putting my solution in here in case other folks are trying to get MP to play well with Elegant Themes.

    The theme settings have a section called Number of Posts displayed on Archive pages. Pretty simple really.

    Its located on the General Settings page of the ePanel.

    This is resolved.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.