CDSSO Isn't logging user into mapped domain

I have domain mapping set up on a MS network running WP Version 4.6.1

These are commented out in config

// define('DOMAIN_CURRENT_SITE');
// define('PATH_CURRENT_SITE', '/');
// define('SITE_ID_CURRENT_SITE', 1);
// define('BLOG_ID_CURRENT_SITE', 1);
//define('ADMIN_COOKIE_PATH', '/');

It seems to be the same issue as this: https://premium.wpmudev.org/forums/topic/domain-mapping-cross-domain-login-with-https

in short: plugin is working fine as far as domain mapping. However the cross login for subsite Admins is not working. A user logs into https://subsite.example.com and is not logged into http://.subsite.com.

I know this because there's no "logged-in" class on the body (there should be) and a page builder we're using isn't working when trying to edit the page on a mapped domain.

Things I've tried:

- I have updated to the latest domain mapping.
- I have tried CDSSO with and without ansych option.
- I am forcing https in login and admin pages:
- I am NOT forcing https in frontend pages
- When a user logs in, they are redirected to that wp-login splash screen where it asks them to wait for 5 seconds
- I was using comet cache plugin but I disabled to test if it work work again - no go.

The really weird part, it does work for me in one my browsers - probably from when it used to work - the cookie is saved. However, when I login in an incognito browser, it doesn't work.