Certain elements out of line after Upfront updates

The problem is with the search bar within this plugin. After the updates, the alignment went out of whack. Do you have an idea as to what might have caused this?

  • Huberson
    • Recruit

    Hi there,

    Try adding the following css for the search box

    .tg-nav-under .tg-search-holder .tg-search-icon {
    position: absolute;
    z-index: 8;
    left: 0;
    }

    .tg-nav-under .tg-search-holder .tg-search-clear {
    position: absolute;
    top: 0;
    right: 0;
    }

    .tg-nav-under .tg-search-holder input.tg-search[type="text"] {
    border: none !important;
    padding-left: 21px;
    }

    .tg-nav-under .tg-search-holder::before {
    height: 57px
    }

    It should take care of aligning the icons and remove the border.

    Do let us know if it does fix the issue and we’ll look at that.

    Regards,

    Huberson

  • Huberson
    • Recruit

    Hi,

    The attachments you uploaded failed to load. I check the search element from the site and it's like the above css is not present at all on the page.

    I tested the css again and it fixed the search box elements

    Try do add that one at the bottom of your existing styles and make sure the css is saved

    .tg-nav-under .tg-grid-area-top2 .tg-search-holder .tg-search-icon {
    position: absolute;
    z-index: 8;
    left: 0;
    }

    .tg-nav-under .tg-grid-area-top2 .tg-search-holder .tg-search-clear {
    position: absolute;
    top: 0;
    right: 0;
    }

    .tg-nav-under .tg-grid-area-top2 .tg-search-holder input.tg-search[type="text"] {
    border: none !important;
    padding-left: 21px!important;
    }

    .tg-nav-under .tg-grid-area-top2 .tg-search-holder::before {
    height: 57px
    }

    It's the same code but a bit more specific.

  • Ciro Bey
    • WordPress Warrior

    Hey there Huberson

    They didn't get uploaded for some reason. I had removed the code after I took those.

    The new code is a lot better. The search box is a bit shorter though and I noticed the cursor when typing is pretty close to the search icon.

    What is causing this issue and is the issue temporary?

    Best Regards

  • Kasia Swiderska
    • Support nomad

    Hello Ciro,

    My (wild) guess is that some new styles from Upfront update started overwriting some of styles that were responsible for the display of search bar. However – that is just a guess – I would need to have access to site that was not updated and updated to track styles and then see where the difference come from. Then I could say for sure what caused this issue.

    Do you have maybe staging site where you could restore backup from before the update?

    kind regards,

    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.