Changing roles for access for in-page SEO metabox isn't working

I'm running a multisite with Smartcrawl. Each site has it's own setup, but only the settings page is on network level.
When I change the roles for access in in-page SEO metabox it isn't visible to that roles. when I login as a super admin I see the metabox, but when I login as a site admin I don't see it.

  • Adam Czajczyk

    Hello Menno

    I hope you're well today and thank you for your question!

    I have checked your site and I can see the issue there. I'm aware that my colleague during the chat seemed to be able to replicate that on his own setup but nor me neither my other colleagues were able to experience the same issues.

    Having said that, I tend to suspect some issue specific to your setup. I've been checking options there, I've also checked wp-config.php file (I assumed that there might have been some "leftover" define for multisite from some much older version of the plugin but there's none), I also checked your mu-plugin... This all seems fine.

    However, the behavior is not expected therefore I'm suspecting either a conflict or that this is related to user roles - if those were adjusted on your setup in any way. That being said:

    1) Did you make any changes in any way to default user-roles? I mean mostly granting/revoking some capabilities either using some plugin or with some custom code?

    2) Could you please run a full conflict test (including theme switching)? To do this please follow this flowchart here:

    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Let me know about results, please, and we'll then decide how to proceed with further troubleshooting.

    Kind regards,
    Adam

  • Adam Czajczyk

    Hello Menno

    I created a staging from my multisite with only Smartcrawl enabled and this issue is still there.

    Would you mind providing me with full access to that staging site?

    As the issue occurs there even with only Smartcrawl enabled, it would be helpful if I could work on that staging site - I could safely do any possible tests and changes to solve that, without affecting your live site performance. And once the issue is solved, solution could then be applied to a live site.

    To provide me with full access to the staging site, please send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password) - cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site

    Please use our contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question

    Best regards,
    Adam

  • Adam Czajczyk

    Hi Menno

    Thank you for your patience. I've tested it more and I believe I found what seems to be a bug or a glitch in our plugin. I've sent you more details about it in my e-mail response.

    However, in case somebody else struggled with this, I'm posting a workaround here as well:

    The issue description:

    If on "Network Admin -> SmartCrawl -> Settings -> User Roles" page the "In Page SEO Meta Box" is set to any role different than "superadmin" but also on "Network Admin -> SmartCrawl -> Settings -> General Settings" the "Sitewide Mode (Network Level Changes Only)" option is disabled - only superadmins will have access to in page seo meta boxes on sub-sites anyway. If additionally "Settings" option in for "Site Owner Permissions" is disabled on "Network Admin -> SmartCrawl -> Settings -> General Settings" page, there's no way to make those in page meta boxes available to anyone but superadmins.

    A workaround (if you wish/need to keep network settings intact):
    ?
    ?1. Login as a super-admin
    ?2. Go to "Network Admin -> SmartCrawl -> Settings -> General Settings" page
    ?3. In "Site Owner Permissions" section enable the "Settings" option
    ?4. Go to the sub-site dashboard
    ?5. Go to "SmartCrawl -> Settings -> User Roles" page
    ?6. You'll notice that regardless of whatever is set in Network Admin settings, the "Access" for "In Page SEO Meta Box" there is set to "Superadmin" role - change that to the role you want it available for and save settings
    ?7. Repeat steps 4-6 for all sub-sites you want In Page Seo Meta Box to be available for other roles than superadmin
    ?9. Go back to "Network Admin -> SmartCrawl -> Settings -> General Settings" page
    ?10. In "Site Owner Permissions" section disable the "Settings" option again
    ?
    ?The settings that you just set will stay there, providing access to the SEO meta box.
    ?

    I have already reported this to our developers so they could investigate and fix that with future releases.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.