Changing Taxonomy Settings Broke the Directory

I'm working on a new site using the Directory plugin and was about 50% of the way through the configuration and theme. This morning I changed a network wide custom taxonomy from non-hierarchical to hierarchical and it broke the directory. I can still access my listings from the admin area, but I get 404 pages from the client side.

The listings page, my listings, etc., all exist in the DB still. They just can't be viewed as pages from the website.

I'm using the most recent install of Wordpress and Directory. I'm also kind of behind on a deadline for this project, so timely help would be greatly appreciated. :slight_smile:

  • aecnu
    • WP Unicorn

    Greetings troycdunn,

    Thank you for this great question and bringing this significant issue to our attention.

    What is the URL to your Directory installation?

    Have you tried resetting your permalinks?

    Lets see what we are working with:
    WordPress 3.4.1?
    MultiSite or Solo?
    Buddy Press 1.5.6?
    Theme name?

    Do you maintain regular backups of your site and/or your database?

    Please advise.

    Cheers, Joe

  • Troy
    • Site Builder, Child of Zeus

    BOOM!

    I reset my permalinks and that fixed it.

    Just for future records, if anyone else runs into this:

    My site is set to private. Wordpress 3.4.1, Multisite, no BuddyPress, Genesis Theme Framework, Rackspace Cloud Hosting, CentOS, daily backups of both site and DB.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.