Changing to HTTPS resets M2

User has a HTTP multisite. He has everything configured in M2. Then he changes his multisite URL to HTTPS (following all the tables stated here: https://wpengine.com/support/how-to-change-a-multi-site-primary-domain/). He also did a search and replace HTTP with HTTPS in the database. But when the multisite main site url is chaned to HTTPS, M2 data is getting reset completely. M2 acts like it is a brand-new installation and is not configured at all.

  • Lindeni Mahlalela

    Hello Alexander

    I hope you are doing great today. I am sorry for the delayed response from our side and I hope that hasn't caused a lot of inconveniences for you and I hope we resolve this soon.

    In an attempt to try and replicate this issue I have created a fresh WordPress Multisite with subdirectory install. I have setup Membership 2 on the main site and afterwards I have followed the same guide you followed to replace the http domain with https. After that WordPress logged me out as result of this change. I logged in again and checked everything was looking fine, all Membership 2 Pro settings were left intact and I could not replicate this issue.

    Would you mind sharing with us the details about your setup and the steps on how to replicate the issue. Please also share access to your site by enabling support access via the WPMU DEV dashboard plugin. Is it still necessary for you that we trace this issue or you have already migrated the site to HTTPS? If you undo those changes in the database and then do them again, does that reset Membership 2 Pro as well?

    Please let us know if you still need help with this and if you still do please share with us the details of your setup and the steps to replicate the issue and don't forget to enable support access to your site so we can have a closer look.

    I hope to hear back from you soon.

    Have a nice day.
    Mahlamusa

  • Lindeni Mahlalela

    Hello Alexander

    I have tried to access the wordpress dashboard using the credentials you shared, I was able to login to the site but the account does not seem to have the required role to access wp-admin. When I tr to got to /wp-admin on the site I get the following error message:

    Du hast versucht, auf das "BANKINGCLUB" Dashboard zuzugreifen, hast aber nicht die ausreichenden Rechte dazu. Falls du glaubst, du müsstest Zugriff auf das "BANKINGCLUB" Dashboard haben, dann kontaktiere den Netzwerk-Administrator.

    Which according to Google Translate means:

    You tried to access the "BANKINGCLUB" Dashboard, but you do not have sufficient rights to do so. If you think you should have access to the "BANKINGCLUB" dashboard, then contact the network administrator.

    Could you please give that account Superadmin access or grant support access by following this guide let me know once you have done that by replying on this thread, if you decide to share a new admin account please use our secure contact form in the contact form choose "I have a different question" then in the subject line write "Attn: Lindeni Mahlalela" to make sure it gets assigned to me, lastly: In the Message box include:

    - WordPress Login Details (username, password and login url if you have a different one for testing)
    - Link back to this thread for reference.

    Once we have that we will continue troubleshooting and report back to you here. I look forward to your response.

    Have a nice day.
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.