Chat 2.0.1 - Missing WYSIWYG icon / Admin cannot Open/Close Chats

Top notch plugin! Love the newest Buddypress integration.

Admin cannot open and close sessions via the gear (only option is sound off) Administrator is set up for all the proper options (after all...it is super admin :wink:)
Moderator/Author can open/close sessions via the gear.

But, neither admin or moderator can see the tinyMCE option just above post window, yet it is set up as visible to those roles for posts and pages.

Please advise. For the first where Admin cannot open/close chats on the chat window, I have no idea where to look. For the second issue, I am wondering if I need to find tinyMCE in my installation and do a compare to see if any files have a core change?

  • Paul
    • The Green Incsub

    @kim,

    Welcome back!

    Since you were a tester of the early betas I want to first make sure your setup is clean. Please follow these steps.

    1. First I want you to deactivate the plugin.

    2. I'm assuming you can drop database tables. The reason I need you to manually drop these is the upgrade logic within the 2.0 released plugin only assumes you are upgrading from Chat 1.3.x. During the beta the tables were still be changed.

    I would like for you to drop three tables: wp_wpmudev_chat_log, wp_wpmudev_chat_message and wp_wpmudev_chat_users (Note your table prefix may be different.

    3. Next, I want to you remove some options from your wp_options table. Again your prefix might be different. All the options being with 'wpmudev-chat%' as the option_name field.

    Here is a SQL query to select those items.
    SELECT * FROM wp_options WHERE option_name LIKE 'wpmudev-chat%'

    Once you have done the above three steps you can now reactivate the plugin. This will recreate the table with the most current structure.

    I just tried viewing your site and see a JavaScript error coming from the floating social plugin. See image. Try disabling the floating social plugin.

    As for the other comment from your server guy. Yes, this is a chat plugin. It will impact your server load. There is simply no way around that.

  • kim
    • WPMU DEV Initiate

    Done as instructed ... deactivated, removed tables and options.
    Admin still cannot open or close chat (tested in Chrome and Firefox) Yet Moderator can.
    Socialize is off, and still no icon for the chat wysiwyg. If I did a compare of the tinymce files, where would they be?

  • Paul
    • The Green Incsub

    @kim,

    Maybe I'm missing something. When I view the page http://thecreativepixel.com/chat/ and look at the source I don't see the chat box div which the shortcode added to the page output. So the page appears blank.

    Admin still cannot open or close chat (tested in Chrome and Firefox) Yet Moderator can.

    Just so we are clear there are two settings.

    One setting the Chat > Settings Page then 'WYSIWYG Button' tab will control on what post type and by what WP role the chat shortcode button will appear.

    Second is the Chat > Settings Page then 'Authentication' tab which controls login options and what role is moderator. The moderator is the person who can moderate the chat on the fron-end. There is still a bug in that SuperAdmin under Multisite is not seeing full ability. So try switching to local site admin.

    If I did a compare of the tinymce files, where would they be?

    Would be in the bowels of WP core in the wp-admin area. Not going to touch that. Sorry. The Chat plugin does not directly modify the WP core code. Just uses proper hook to add needed content.

  • Paul
    • The Green Incsub

    @kim,

    Also make sure you are upgraded to Chat 2.0.2 released today. Might fix the WYSIWYG issue on your end.

    The SuperAdmin issue was reported in another thread. Then we noticed the sam same issue on the front-end moderator. I can explain the details of the bug if needed. But want to make sure this is not something else.

  • kim
    • WPMU DEV Initiate

    Upgraded to 2.0.2

    You may have seen a blank because I was editing and purging the cache

    wysiwyg is back... thank you ... but it doesn't give me what I was used to before... now it just gives [chat ] as the short code (No ID or anything else)

    I am superadmin on multisite... so that is probably why I don't have the options according to your issue notice above. I will use my alter ego until this is resolved.

  • Paul
    • The Green Incsub

    @kim,

    wysiwyg is back... thank you ... but it doesn't give me what I was used to before... now it just gives [chat ] as the short code (No ID or anything else)

    That is by design. So here is the process. You go to Chat > Settings Page and setup some default options for Pages/Posts for your site. Then you go edit a Page and click the WYSIWYG button. You can override the defaults set from Chat > Settings Pages. Maybe you want the message input at the top, etc. When you click the insert it should put in some parameters. The ID was purposely removed. We are now defaulting to the Page ID, Similar on Widgets. When you create a sidebar widget the widget is assigned a unique ID already by WP. No need to generate a new ID for Chat within the widget.

    Ok... I just have to say... really! This chat module blows me away... the integration with buddypress for the private chats... TOTALLY Cool!!!

    Was hoping you would like that. In 2.0.2 there is a new tab on Chat > Settings Common for setting some BuddyPress defaults. Will be adding more options later.

    So what else is needed? What about your moderator issue. Solved? Still open?

  • kim
    • WPMU DEV Initiate

    Great explanation on the change. Got it.

    I will watch for Buddypress changes.

    The moderator issue is not resolved for my superadmin on a multisite. I cannot use the gear icon to open and close chats.

    Thx

  • Paul
    • The Green Incsub

    @kim,

    I was a little freaked out to see your picture in our chat yesterday morning. (because I don't see where you are a member of my site). Please tell me I don't have a security issue.

    Um. What? Was not me as far as I know. Was it the same picture I use on these forums?

    Related to this thread why is t still marked unresolved? Are you waiting on something from me? The last few entries deal with avatar issue which should have been solved on previous versions of Chat.

  • kim
    • WPMU DEV Initiate

    It was your same avatar here (I have a screenshot) as well as if you click on the avatar, it says @paul. Looking in the database, it is a gravatar and there is an IP as well. How can someone use our chat without being a member? I want that restricted to members only.

    It is still open because the network (multisite) super admin cannot open or close chats.

  • Paul
    • The Green Incsub

    @kim,

    I'm still seeing the public login form. In Chat there are two sets of settings. First check Chat > Settings Page then the Authentication tab. Only set the login options you want: Public, Facebook, Twitter, etc.

    Then since this is a Page go to edit that page. Find the chat button on the Visual editor. Click it. Check the Authentication tabs make sure you are only allowing the login method you want.

  • Paul
    • The Green Incsub

    @kim,

    what is Network user

    This is more legacy. Needs to be removed. Still Network User is related to Multisite user. Which is not related to your issue since you are allowing Public Users. Again you need to check both the Chat > Settings Page also the shortcode. Provide screenshots of both please.

  • Paul
    • The Green Incsub

    @kim,

    Actually my fault. False alarm. I was looking at two different system. So on my setup for example I have the Chat > Settings Page with only the checked WordPress User. See first image.

    Then on the Page shortcode I also only have the WordPress user selected. See second and third image.

    When I view the page as a non-authenticated WordPress user I don't even see the chat box. Just the page title and any content before or after the chat shortcode. See fourth image.

    So my question is on your settings what do you have?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.