WordPress Chat Configuration

I just purchased this plugin, and it doesn't work. It installs, and you can see it embedded on the page.
- type chat text
- hit enter
- nothing appears

So I tried it on one of my other sites to see if I had more luck.
- type chat text
- hit enter
- nothing appears

Then - I click on the screen where the chat is supposed to appear - and the chat appeared.

Wouldn't be good if it worked this way, but thought I'd try the same thing on the first site. No luck.

So then I tried it with a brand new site with the TwentyTen theme - and it worked. I switched to another theme from a specific company - and it no longer worked. (no other plugins are activated). I switched to another theme from yet a different company, and it didn't work.

Not a happy camper.

  • DavidM
    • DEV MAN’s Mascot

    Hi iHuman and welcome to WPMU DEV!

    Just to be sure I understand you correctly, you're saying the plugin works fine with Twenty Ten but not with those few other themes? Is that correct?

    If that's the case, you can take a look using FireBug or another inspection tool to see where exactly the trouble resides (ie. what errors are coming up). There's a great tutorial on FireBug over at BuddyDress if you're unfamiliar with it.

    Cheers,
    David

  • iHuman
    • WPMU DEV Initiate

    No - it worked on a brand new site with the TwentyTen theme. If I switch this site to the TwentyTen theme, it doesn't work.

    In fact, it looks like it's actually interfering with my ability to even login on Wordpress now.

    Very disappointing way to start my experience with https://premium.wpmudev.org/. I've bought quite a few premium plugins from codecanyon ... the difference is - they work. You guys should test yours on more setups before releasing them.

  • Eric G.
    • The Crimson Coder

    @iHuman

    I am also curious and do not understand your last response.

    No - it worked on a brand new site with the TwentyTen theme. If I switch this site to the TwentyTen theme, it doesn't work.

    My limited knowledge is that the TwentyTen theme is the standard that all other themes should follow. So that is why many will ask if it is working on that. Once you get out of the skeleton of TwentyTen things can actually conflict without it being the fault of either developer (rare, but can happen).

    Anyway, you will hopefully find the staff at WPMU DEV will be most helpful in tweaking the plugin or even the theme to get it working for you. I moved more towards WPMU DEV because Code Canyon authors are not obligated to give support and when they do, they can find it easy to blame the problems on the theme (which is funny because often the themes I used were from ThemeForest!).

    I know this doesn't fix your problem, but thought I could give you some wisdom from my experiences with both.

  • iHuman
    • WPMU DEV Initiate

    It makes absolutely no sense. I'm actually a seasoned web developer - and have never worked with a plugin that has this issue.

    Here's what makes no sense:
    - I have Wordpress setup as multi-site
    - I have several sites hosted
    - on the site I purchased this plugin for, it does NOT work
    - there are no other plugins installed other than Chat, so it can't be a plugin conflict
    - I have one site on the server that is a fresh install (same multisite WP)
    - I installed chat there, and can get it to work with the TwentyTen theme
    - I switch to the same theme I'm using on the site where I really want it to work - and it works

    Very frustrating...

  • DavidM
    • DEV MAN’s Mascot

    Hi iHuman,

    I've got the plugin running currently in a number of different configurations including regular and multisite setups. And I'm not seeing any issues with any of them.

    However, that's not to say it's impossible for the plugin to have conflicts with other setups. I mentioned Firebug previously because I assumed you were experiencing a theme issue, given my understanding of the information at hand.

    Though I did forget to ask for a url. Could you possibly provide us a url to take a look at?

    Also, this added bit of information regarding your multisite setup does help, for sure. And just to check a few things, do you have the plugin network activated on that site or is it only activated on that one sub-site?

    Also, could you let us know which version of WordPress you're on?

    Thanks,
    David

  • iHuman
    • WPMU DEV Initiate

    @Eric G. - no, it's not working
    @DavidM

    I'm using Wordpress 3.1.2 for all sites.
    You can look at http://motion.tv/chat (the non working site)

    I've been spending hours trying to troubleshoot this (not what you expect from a paid plugin)

    The one thing I've been able to determine so far, is that (even though authentication is set the same in both Chat instances) - if I look at the mysql message log - anything submitted from the site that is working includes an avatar email address and moderator set to 'yes'.

    In the site that is not working, it submits without an avatar email address, and moderator set to 'no.

    Both sites are now using the same template - so it is not a template issue.

    All plugins are disabled except for chat.

  • iHuman
    • WPMU DEV Initiate

    So even on the my sites where it works, it continuously making ajax request alternating between waiting and uploading 0% in the status bar.

    I've spent over 8 hours trying to troubleshoot this plugin. Can't believe I had to pay for it on top of this. It is becoming the multi-hundred dollar plugin. Definitely not worth it. I'm now going to get back to work on other projects that have been interrupted by my purchase of this plugin.

    Hopefully your developers can fix it. If the issue can't be resolved by this evening, please refund my account.

    elaine

  • S H Mohanjith
    • Developer

    I believe you have set your wp-admin URL to be on a different domain from the site URL and force a redirect there. Chat plugin makes an ajax request to http://motion.tv/wp-admin/admin-ajax.php which gets redirected to http://motiontvold.zocoloco.com/wp-admin/admin-ajax.php (Look at firebug network logs, not click the link here). When it come to ajax requests it must be of the same origin.

    Please see http://codex.wordpress.org/AJAX_in_Plugins#Ajax_on_the_Viewer-Facing_Side before you ask why we make a request to a file within wp-admin.

    Since javascript doesn't has a same origin policy there is no fix other than reconsidering wp-admin redirect. If there is lot of demand for cross domain chat from members I might consider using a tiny flash file to enable cross domain chat but even that will require extra files to be placed in the document root.

  • iHuman
    • WPMU DEV Initiate

    This is confusing considering the nature of WP multisite installations.

    wordpress install: domain.com
    wordpress sites:
    site1.domain.com > maps to realdomain.com
    site2.domain.com > maps to anotherdomain.como
    site3.domain.com > maps to bestdomain.com

    Are you saying you need to edit the database for each site, setting the 'siteurl' option to be the mapped domain?

    Also, a couple other questions...
    I noticed that it says that Chat has an update. When I update it from network admin, it becomes Chat Lite. So I reinstalled.

    I've installed the DEV notifications - but it's not available to select as a plugin in each site. Is the only option to network activate that plugin?

    Even with it installed, it is still showing that Chat should be updated to .4

  • Aaron
    • CTO

    Set your domain mapping to use either the mapped domain or user defined and it should work fine. You have a very non standard setup there and hence you are the first out of thousands of users to report this problem.

    Sorry for your bad luck! And I hope that you would be able to realize that this is not the norm experience with our products.

  • iHuman
    • WPMU DEV Initiate

    Hi Aaron,

    thanks for the reply.

    I'm curious - why is my setup 'not the norm'? Aren't most multisite installations setup how I described above? (I'm not referring to WPMU - but the WP 3x multisite installs).

    I'm willing to give your other products a try, but I was very surprised to have this happen...as I've never had it happen with any other plugin in the past.

    thanks,
    e

  • iHuman
    • WPMU DEV Initiate

    Serious? You mean a domain mapping of subdomain.domain.com mapped to myrealdomain.com is rare? I would have assumed that everyone would use the multisite in that way. Otherwise, they are just subdomains. Interesting.

    My guess is I'm also not using the WPMU Dev mapping plugin. Maybe it works differently.

  • iHuman
    • WPMU DEV Initiate

    ok got it...

    Yea, the WordPress MU Domain Mapping plugin provides the option to have the admin domain map to either the actual domain or the root domain for the Wordpress install. It's a handy feature if you have multiple sites that you admin. But because of the situation with the Chat plugin, I've now disabled this feature.

    Looks like the chat is working fine. Thanks @aaron, @S H Mohanjith and @DavidM for your assistance.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.