Chat emoticons not showing

For some reason, only a few of the emoticons are showing in the smiley box:

  • Rupok
    • Support Ninja

    Hi angeljs,

    Sorry to hear the inconvenience you are having. It might happen for network related issue, I'm not sure though. I mean, maybe some icon images got loaded but other could not be loaded.

    Can you please try clearing cache and cookies from your browser and try again? Can you please try from a different browser? Can you please try from a different computer/network?

    If this doesn't solve the issue, can you please do a plugin conflict test just to make sure no other plugin is causing this? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Actually, I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this? Please provide the URL where we can see the chat window live.

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know the result of your tests and confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Rupok
    • Support Ninja

    Hi angeljs,

    Sorry for the delay from our end and thanks a lot for granting Support Access.

    I logged in with Support Access, did a plugin conflict test as I suggested above and found that your "Custom Smilies" plugin is causing this issue. I deactivated that plugin for a minute and all your chat emoticons started appearing properly. Please check the attached screenshot for reference.

    Can you please talk to the developer of that plugin regarding this? Please check the attached screenshot for reference.

    This is how WordPress renders smilies natively:

    This is how that plugin is rendering smilies:

    So disabling this "Custom Smilies" plugin will solve the issue for you.

    Please let us know if you have any confusion or any further query. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

  • Rupok
    • Support Ninja

    Hi angeljs,

    Yes. You can make the emoticons larger by using the following Custom CSS Code:

    div.wpmudev-chat-box div.wpmudev-chat-module-message-area ul.wpmudev-chat-send-meta li.wpmudev-chat-send-input-emoticons ul.wpmudev-chat-emoticons-list li {
      font-size: 20px;
      height: 22px;
    }

    You can add this to a theme's stylesheet, in a child theme, or using a plugin like My Custom CSS.

    I'm afraid, there is currently no way to add more emoticons for chat box. But I think, that will be a nice feature. So I'm moving your thread to our Features and Feedback section. More people liking this idea, more chances our developers will work on this and will include this feature in our future releases.

    Have a nice day. Cheers!
    Rupok

  • angeljs
    • The Crimson Coder

    Thanks for the suggestion, but it didn't work. And now I'm having another problem involving the emoticons - when I type a chat and add an emoticon, the chat doesn't send (i.e. doesn't appear in the chat box). When I type just text without the emoticon it appears just fine.

  • Rupok
    • Support Ninja

    Hi angeljs,

    Sorry to hear the it didn't work. I logged in with Support Access to check the issue, but I don't see the Smilies icon in the chat box now. Please check the attached screenshot for reference.
    https://monosnap.com/file/Tcf5LbbMt2BbcbfpVAtRTURJA0Gf5m

    Did you change anything since my last reply? Can you please tell us how we can see those smilies back so we can see the issue live and try to fix this for you? I've checked the Chat Page Settings, but Emoticons are enabled in Message Input tab. So I'm not sure why this is not appearing.

    Please let us know how we can see the issue live on your site. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Rupok
    • Support Ninja

    Hi angeljs,

    So sorry for the delay from our end. I've just tested the native chat smilies on my test site and it's working fine here. So I think, this is your site specific issue.

    Now again, this could be caused by another plugin. Just to make sure no other plugin is causing this, can you please do a plugin conflict test again? Please *deactivate* *all* plugins except the Chat plugin, and check if the smilies work. If it works, then start activating plugins one by one and check at which point, smilies stops working again. That plugin is the one which is conflicting. To know more about plugin conflict test, you can check this guide again: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let us know if the smilies don't work even after disabling all plugins. Also let us know the result of your plugin conflict test. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Rupok
    • Support Ninja

    Hi angeljs,

    So sorry to hear this. Is it anyway possible to create a clone of your site where we can continue troubleshooting and try to fix this? And when we can find out the reason behind this, and get a solution for this issue, we can then apply that fix to your live site. What do you think? As I could not regenerate this issue on my test site, so the only way to troubleshoot this issue is troubleshooting on your site.

    You can create clone of your site using the Duplicator plugin.

    Please let us know what you suggest. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.