Chat noauth_login_message seems to be broken

Hi folks,

I’m putting a chatbox into a page and have set the “noauth_login_message” when creating it, however I am still getting the default “To get started just enter your email address and desired username:” login message when the chat is displayed.

Is this a bug, or how can I get it to display my own message above the login? Ideally, I don’t want to capture e-mails at all – just a name – is there any easy way to do this?

Chatbox code below.

Thanks!


[chat blocked_ip_addresses_active=”disabled” box_input_position=”top” box_emoticons=”enabled” row_name_avatar=”name” row_time=”enabled” login_options=”author,bbp_keymaster,bbp_moderator,bbp_participant,contributor,editor,public_user,subscriber” noauth_login_message=”Please note that your e-mail is not displayed and not stored” noauth_login_prompt=”Please enter your details to join the chat” ]

  • Predrag Dubajic
    • Support

    Hey ideasgarden,

    Hope you’re doing well today :slight_smile:

    noauth_login_message is shown when you use login form for non logged in users, so if you add this to your shortcode noauth_view=”login-only” it will display login form on load and your message above it.

    Ideally, I don’t want to capture e-mails at all – just a name – is there any easy way to do this?

    Unfortunately this is not something possible with Chat plugin and e-mail is mandatory.

    You could try using this solution that was provided quite some time ago but it’s not something we recommend doing as it includes changing plugin core files:

    https://premium.wpmudev.org/forums/topic/how-to-use-the-chat-plugin-without-e-mail#post-690736

    Best regards,

    Predrag

  • ideasgarden
    • Design Lord, Child of Thor

    Hi Predrag,

    Thanks for your speedy reply.

    I think you’ve missed my point – I know that it should display my custom message above the login fields for non-logged-in users, however it doesn’t, it ignores my message and displays the default “To get started just enter your email address and desired username:” message.

    I added noauth_view=”login-only” as suggested but it has no additional effect.

    Thanks,

    Richard

  • Predrag Dubajic
    • Support

    Hi Richard,

    Hmm, strange, I tested your shortcode on my installation before my comment, here’s what’s in my chat page:

    [chat blocked_ip_addresses_active="disabled" noauth_view="login-only" box_input_position="top" box_emoticons="enabled" row_name_avatar="name" row_time="enabled" login_options="author,bbp_keymaster,bbp_moderator,bbp_participant,contributor,editor,public_user,subscriber" noauth_login_message="Please note that your e-mail is not displayed and not stored" noauth_login_prompt="Please enter your details to join the chat"]

    And here’s how it renders on front end:

    “To get started…” message can be easily hidden with some CSS, we can get back to this when we get the first part working for you :slight_smile:

    Would you mind allowing support access so we can have a closer look at this?

    To enable support access you can follow this guide here:

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,

    Predrag

  • ideasgarden
    • Design Lord, Child of Thor

    Hi Predrag,

    Thanks again for getting back., yes it seems you have replicated exactly what’s happening at my end – you are getting the default message instead of the custom one you specify.

    It was for a live broadcast last night, so as a workaround I just hid the message altogether using CSS, so it wouldn’t be a great site to test further on! But seeing as you are able to replicate, can you debug your test site? On the face of it it seems to be a small bug in the code somewhere that is ‘forgetting’ to pull in the custom message when specified.

    Cheers,

    Richard

  • Milan
    • WordPress Wizard

    Hello Richard,

    Hope you are well today :slight_smile:

    I can also replicate this behaviour so I have flagged our developer to fix this. Hopefully they will start their work to fix this soon. I’ll try to find temporary fix for you and if I get any I will update you here. We appreciate your cooperation here. :slight_smile:

    Cheers,

    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.