Chat Plugin Available not working

Can't get chat to work because I can't seem to get it changed from unavailable to available. I had a "subscriber" log-in and they could show themselves available, but when they would type in the chat box, it doesn't actually enter the conversation. I've disabled plugins and played with settings until I'm blue in the face.

  • Adam Czajczyk

    Hello GreenTiger,

    I hope you're well today and thank you for your question!

    I checked your site and I have then changed the "Select Polling Source Type" option on "Chat -> Settings Common" page from "Plugin ajax" to "WordPress ajax" and the chat seems to be working now.

    I suppose you have have tried either our Defender plugin or other "security-type" plugin before, is that right? This issue usually happens when the php execution in folders is blocked and this changes fixes it.

    You may however want to take a look inside the "/wp-content" folder of your WordPress and see if there's a .htaccess file there. If you wish me to drill down to the root cause of that issue, share the content of that file with me - if it's there please :slight_smile:

    The chat should however work fine now with that new setting.

    Best regards,
    Adam

  • GreenTiger

    Hi Adam,

    I changed that setting back and forth at least 3 times this morning and never got a positive response. Checked for the .htaccess file and didn't find one in the /wp-content/ folder. In the past, using the Wordpress Ajax setting makes it so s-l-o-w I just couldn't do it. I'll try this again and see how long it lasts.

    There is something funky going on with this site. I am struggling with host and polling intervals. Three times in the past week, the only way I can gain access to the site is to disable all plugins from C-Panel and get in from there. That's why you aren't seeing Defender and some other plugins. I've fussed around repeatedly trying to figure out what is breaking this site.

    Here is the .htaccess file... is this the one you wanted to review?
    ## WP Defender - Prevent PHP Execution ##
    <Files *.php>
    Order allow,deny
    Deny from all
    </Files>
    ## WP Defender - End ##

    any help would be appreciated. The chat plugin for this site has proven invaluable!

  • Adam Czajczyk

    Hello GreenTiger,

    Thank you for your response!

    What you described seems to me like the host was providing resources that are not sufficient to power your site. It's a bit difficult to say though whether it's just a server perfomance or e.g. a limit on a number of concurrent (or subsequent in a given period of time) database queries or something even more complex. I think it would be good to ask your host what their server logs say about your site performance/resource usage and this may help you either optimize the site or... decide to move to other host :slight_smile:

    As for the Chat plugin. In a .htaccess file please change this line

    Deny from all

    to

    Allow from all

    and you should be able to switch Chat back to use the "Plugin Ajax". If you enable Defender, make sure that the "Prevent PHP Execution" option is not enabled and "Plugin Ajax" option will still work then. I know that Defender suggests "Prevent PHP Execution" in order to increase site security but if for some reason (such as performance) you need to stick to "Plugin Ajax" for chat, the plugin must be able to execute it's own ajax file which is written in PHP.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.