Chat plugin gets spammed and crashes the server

I recently installed the Chat plugin on our members site, in the members area. when we turn the chat on our site CPU usage goes to 90% as the Chat plugin gets SPAMMED. We connected our host. We are on a dedicated server and this is what they said:

Hello,

There appear to be a lot of IPs hitting your server in what looks like attempts to spam the mavericktrading.net chat / comments file. These are the IPs, with the number of active connections listed first:

18 108.162.221.168
18 108.162.238.86
18 108.162.241.180
18 108.162.245.160
18 173.245.50.143
19 108.162.221.174
19 108.162.245.155
19 173.245.52.76
19 173.245.54.159
23 108.162.219.220
24 173.245.50.168
24 173.245.52.64
29 108.162.219.169
30 108.162.237.78
31 199.27.128.135
33 173.245.56.154
34 199.27.133.31

Here is an excerpt from the log:

/usr/local/apache/domlogs/mavericktrading.net:199.27.133.31 - - [20/Jan/2016:14:11:01 -0500] "POST /members/wp-content/plugins/wordpress-chat/wpmudev-chat-ajax.php HTTP/1.1" 200 63 "http://mavericktrading.net/members/class/2015-year-in-review/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36"
/usr/local/apache/domlogs/mavericktrading.net:199.27.133.31 - - [20/Jan/2016:14:11:04 -0500] "POST /members/wp-content/plugins/wordpress-chat/wpmudev-chat-ajax.php HTTP/1.1" 200 63 "http://mavericktrading.net/members/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36"
/usr/local/apache/domlogs/mavericktrading.net:199.27.133.31 - - [20/Jan/2016:14:11:07 -0500] "POST /members/wp-content/plugins/wordpress-chat/wpmudev-chat-ajax.php HTTP/1.1" 200 63 "http://mavericktrading.net/members/class/2015-year-in-review/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36"
/usr/local/apache/domlogs/mavericktrading.net:199.27.133.31 - - [20/Jan/2016:14:11:10 -0500] "POST /members/wp-content/plugins/wordpress-chat/wpmudev-chat-ajax.php HTTP/1.1" 200 63 "http://mavericktrading.net/members/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36"
/usr/local/apache/domlogs/mavericktrading.net:199.27.133.31 - - [20/Jan/2016:14:11:13 -0500] "POST /members/wp-content/plugins/wordpress-chat/wpmudev-chat-ajax.php HTTP/1.1" 200 63 "http://mavericktrading.net/members/class/2015-year-in-review/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36"

I have blocked the IPs. Unfortunately, this may continue to happen so long as the chat plugin is installed.

Not sure what to do. This seems to be a major flaw in the plugin if it can be spammed from inside a members site seconds from being turned on.