Chat plugin not working

I have installed chat plugin, but I have run into two main issues.

1. After login in with two active users, I am not seeing any active users available in the chat area although this is enabled.

2. When I type new messages, they are not been display and the word count is not working as it remains at zero even when I type long texts.

Thanks for all the help

  • Adam Czajczyk
    • Support Gorilla

    Hello Gregory,

    I hope you're well today and thank you for your question!

    I have visited your site and I noticed that there's an error reported in a browser console stating that one of the chat scripts has returned an "unexpected token".

    I have then changed Polling Source Type from "Plugin Ajax" to "WordPress Ajax" in Chat "Settings Common" section and that seems to fix that. I was then able to use the chat as expected. I left that setting this way for now.

    I presume though that the core of the issue may be either WP Super Cache or Wordfence or combo of these two. Caching + Security tightening can interfere with WP ability to directly execute scripts that are located inside plugin folders.

    That being said, if that works for you know and you are not getting "tons" of traffic to the site (like hundreds of more users at the same time) I think you can just leave that set as is and it should be working fine.

    If you are getting a lot of traffic or are expecting to get in future, it may be better to investigate it further and find out what's causing that initial issue. To do this, you would want to start with a full theme/plugin conflict test. First step would be to set chat's Polling Internal back to "Plugin Ajax" so the chat wouldn't work as expected and the the second step would be to follow the flowchart in this article (you may need to scroll the page down):

    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    This should reveal the main culprit that I could then investigate in details.

    Best regards,
    Adam

  • Gregory
    • Site Builder, Child of Zeus

    Thanks for the help.

    Changing from ajax to word press allow me to send messages, but am still not seeing the character count move from 0 of the 450 characters allowed. Also not seeing the messages on the frontend only in the admin area.

  • Predrag Dubajic
    • Support

    Hi Gregory,

    I had a look at your site with different accounts and browsers and I was able to see messages on front end without any issues, you can see in below images chat box from Chrome and Firefox:
    [image pos="0"]

    Can you tell me which browser you're using so I could try testing in same conditions?

    Changing from ajax to word press allow me to send messages, but am still not seeing the character count move from 0 of the 450 characters allowed.

    This one looks like we have a bug in the plugin as I was able to replicate same behaviour on my installation.
    I have created bug report and notified our devs about that, thanks for bringing it up to our attention!

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.