Chat Plugin throws many errors in latest WordPress

Does this support the latest version of wordpress?
After installing, I get a bunch of errors

The plugin generated 237 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

instead. in /home/wp-includes/functions.php on line 3457

Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use
__construct()
instead. in /home/wp-includes/functions.php on line 3457

Notice: Undefined index: header_bg_color in /home/wp-content/themes/gray-whale/inc/custom-header.php on line 48
Skip to content

  • Adam Czajczyk

    Hello @deutschnd,

    I hope you're well today and thank you for your question!

    Our Chat plugin should be fully compatible with the newest WordPress release. However, I can see the same behavior on my site so this is clearly something that needs fixing.

    That being said, I'm reporting this to our developers as a bug and as a quick workaround please edit your wp-config.php file and make sure that the WordPress debugging is disabled like this:

    define('WP_DEBUG', false);

    This should let you get rid of the error.

    I hope that helps!

    Cheers,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.