Chat Questions - speed, logged out, message body

1. Chat is really slow. I have changed polling time to .5 sec and also changed source. It has made no difference at all. It is painfully slow compared to my old FlashChat

2. When someone logs out their avatar remains in the Active Users and in Who's Online. This is really bothering my members. Why are these avatars remaining active when the person is logged out?

3. The time in the chat rooms is posted under the text. Why is the text not beside it. Can you please tell me how to change this.

Thank you.

  • Sajid

    Hi @Mary

    Hope you are doing good today :slight_smile:

    1. Chat is really slow. I have changed polling time to .5 sec and also changed source. It has made no difference at all. It is painfully slow compared to my old FlashChat

    You have to decrease the seconds how often its should check for new messages and display from Chat > Settings Common > Poll Intervals > How often to poll for new messages. The recommended value is 2 or 3 seconds. I have changed the value from 3 to 1 seconds it loads new messages almost instantly. You can also use fraction of seconds like 0.5 to improve speed but not recommended. If its still slow then please follow the instructions mentioned on our project usage page.

    If you have not yet increased the memory allocated to WordPress on your site (standard is 40M), now may be a good time to do so. Add the following to your wp-config.php file, before the line that says “That’s all, stop editing!”:
    define('WP_MEMORY_LIMIT', '256M');
    If you’re on a shared hosting plan, you may want to consider upgrading. Popular sites with lots of traffic and numerous chat instances running simultaneously can quickly tax your server. Contact your host for more on this if you notice things get a bit sluggish.

    2. When someone logs out their avatar remains in the Active Users and in Who's Online. This is really bothering my members. Why are these avatars remaining active when the person is logged out?

    Right now there is no option to remove users when they are logged out. But you can set a specific time of inactivity after that they will be removed from chat list. You can change it from Chat > Settings Page > Users List > Remove Inactive User after (seconds).

    3. The time in the chat rooms is posted under the text. Why is the text not beside it. Can you please tell me how to change this.

    That's the default style of chat room. Right now we don't have any CSS class to target so we can adjust its position. Its adding a BR tag dynamically. I am flagging developer here for their invaluable feedback on this matter. I will post a reply here when I get response from him.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Mary

    I'm wondering if you read my ticket or if you were ever even on my website. I said "Chat is really slow. I have changed polling time to .5 sec"

    Your response was that you changed it from 3 seconds to 1 second, and yet when I went in to check it was still at .5 seconds, which I had set.

    You said " it loads new messages almost instantly." Well my site is still as slow as ever, and it's not just me, it's my moderators as well who are saying that it is terribly slow compared to our old site.

    Re increasing the Memory Limit, I did that when I installed the Chat Plugin and read the documentation.

    Re being on a shared host, I am not. I have a VPS.

    Since nothing has changed, the chat rooms are as slow as ever, could you please escalate this ticket to someone who will actually check my website.

  • Sajid

    Hi @Mary

    Hope you are doing good today :slight_smile:

    I am really very sorry, I missed the (.) before 5 :slight_frown:. I am not sure how but its got missed.

    By mean I have changed the interval, I have done this on my own website hosted on a shared hosting environment.

    I have checked your website and changed the interval but your website is server is taking 2.93 seconds to respond to each request with WordPress ajax, as seen in attached screenshot.

    With Plugin Ajax its still taking 1.93 seconds to respond a request, as seen in second screenshot.

    Then I tested the again on my own website and response time is 735.075ms (0.7 seconds) as seen in screenshot.

    Then I went ahead and deactivated (activated them back again) all other plugins on your website to make sure its not any other plugin is making it slow. But its still the same as seen in attached screenshot.

    Please accept my sincere apologies for confusion and hope that helps diagnose the issue :slight_smile:

    Cheers, Sajid


  • Sajid

    Hi @Mary

    Hope you are doing good today and you are welcome :slight_smile:

    The plugin settings are seems to correct the issue seems to be with configuration or performance. If its your own server then increase its performance or switch to a better host, if not. WpnEngine is one of best and managed hosting server for professional website.

    However, I am again flagging plugin developer here for their invaluable feedback on this matter as well. He might have some better idea for this situation.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.