Chat timestamps

The timestamp on my chat entries is four hours in the future (or east of me). My blog timezone is correct.

It's 11:27AM EDT on my computer. When I sent a chat message, it showed up as 3:27PM.

How do I get the timestamp to match something real. Ideally, each user would see timestamps adjusted for their local time. But I'd at least like to see a timestamp that syncs with my server. I'm pretty sure that Hostgator is not located in Iceland. :slight_smile:

Thanks,
Lee

  • Mason
    • DEV MAN’s Sidekick

    Hiya Lee,

    Thanks for your feedback on this. Can we verify that you have your time-settings set up correctly in WordPress as well?

    Look under Settings>General and make sure your time zone is set correctly here. If it is and this is still an issue, I'll ask a developer to look into this for ya.

    Thanks!

  • greymatter
    • Flash Drive

    From my General tab:
    [UTC-5] UTC time is 2010-10-04 18:51:46 Local time is 2010-10-04 13:51:46

    I never realized this before, but there seems to be a Daylight Savings Time issue, as well. It's currently 2:51pm, but it thinks my local time is 1:51pm.

    And when I chat, I'm getting UTC timestamps.

    Thanks,
    Lee

  • greymatter
    • Flash Drive

    @mohanjith
    The UTC problem is fixed. I now see the local time. However, it's still not adjusted properly for Daylight Savings Time. It's locally 7:57pm EDT, but my chat says 6:57pm. That is also the time shown in my Settings > General tab, so it's consistent. But why is WordPress wrong about DST?

    Thanks!

  • Mason
    • DEV MAN’s Sidekick

    Hiya Lee,

    Maybe a dumb question, but do you for sure have the best time zone picked for your area?

    I live on the East Coast of the US, so I have "New York" as the city in my timezone and it accounts for DST correctly.

    If that's set up correctly, maybe something's giving the wrong time outside of WordPress.. ?

  • greymatter
    • Flash Drive

    There must be something wrong with the way I applied the above patch. I now get the following at the bottom of my page:

    -- SoundManager 2 failed to load (security/load error) --
    soundManager.disable(): Shutting down
    soundManager: Failed to initialise.
    soundManager: Verify that ./soundmanager2_debug.swf is a valid path.
    soundManager: No Flash response within expected time. Likely causes: Loading soundmanager2_debug.swf may have failed (and/or Flash 8+ not present?), Flash blocked or JS-Flash security error.
    soundManager: Getting impatient, still waiting for Flash...
    soundManager::initMovie(): Waiting for ExternalInterface call from Flash..
    soundManager::initMovie(): Got EMBED element (created via JS)
    soundManager::createMovie(): Trying to load ./soundmanager2_debug.swf
    -- SoundManager 2 V2.96a.20100822 (AS2/Flash 8), MovieStar mode, normal polling --

    I am running a Network. I put chat into wp-content/plugins, not mu-plugins, because I thought I read somewhere that's where it belongs. But if I remember correctly, I had initially put chat into mu-plugins. So when I applied the patch, I simply FTP'ed the contents of the zip above into plugins and deleted the chat directory from mu-plugins. Is that right, or do I need to do something different?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.