Chat update 1.0.5 downgrades Chat Premium to Chat Lite

I had Chat Premium plugin 1.0.4 and the system requested to update to 1.0.5 and it downgraded to Chat Lite. Can you tell me where to download Chat Premium 1.0.5? The official page is outdated.

Or maybe there is a Chat Lite 1.0.5 and the system is confusing it with Chat 1.0.4 and is soliciting to update Chat and Chat Lite instead of only Chat Lite.

Need solution!

Thank you Donald.