Cheatin' eh? - Can't Edit My Newsletter

I'm trying to prepare a newsletter to send out and every time I try to save I get get a message "Cheatin' eh? Sorry, you are not allowed to customize this site.

I've been writing and saving for the past hour and now I have to keep going in to the Newsletter that I've saved and try to edit, but again I can't save my edits. Very frustrating!

  • Nithin

    Hi Mary,

    I checked your primary website, and I could see there are many newsletter configured in it. So, I created a new newsletter(Test Letter), and I wasn't able to notice any such issues when creating/editing it. The newsletter saved without any issue, to be sure, I then re-edited it again, and saved it, still it works fine in your system.

    Am I checking the correct site? Could you please explain further where you are seeing this? Is it on any specific newsletter?

    Please advise what I'm missing here, so that we could help get you sorted asap. Have a nice weekend. :slight_smile:

    Best Regards,
    Nithin

  • Mary

    Nithin, this is an intermittent problem and doesn't usually happen until I have been working on a new newsletter for an hour or more. What I did last night was to quit and start Firefox again, a few times, since it kept happening. Then I decided to try it in Chrome. It worked for a few saves but then after about 10 minutes or so I got the same "Cheatin' eh?" message on Chrome.

    I don't know how you can reproduce it because, as mentioned, it only seems to happen after I have a lot of content, and have been working on it for a long time.

    I have taken to saving with every change I make now because of the number of times I've lost whole sections. What happens is that I can work on it, do several paragraphs, and it may save or it may kick me out. When it kicks me out I lose everything I've done since the previous save.

    It has been like this since I first installed.

    I have been reading some things on the internet re the problem and one says, "it is an error indicating that the nonce has expired, which is unusual, since nonces are supposed to last for a day."

    I don't know what a nonce is, but I did notice that it happened for the first time last night at 11:59pm. Could it have something to do with the fact that I do these newsletters late at night, and sometimes into the next day?

  • Kasia Swiderska

    Hello Mary,

    I tried to replicate this issue on your site on Chrome, following your steps, but I could save newsletter dozens times and added lots of content, text and images - tried to edit, remove content. That message haven't showed even once.

    When this message showed before for our members we usually ask to run plugin conflict test - it is possible that some other plugin is interfering with that.

    I'm not sure if you can perform that test, because this is your live site so I'm hoping that enabling debug log will show righ error in debug.log file. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
    define('WP_DEBUG', true);
    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    I would need then to see content of the debug.log file - so please upload it to service like a Dropbox and paste link here.

    You can read about nonces here https://codex.wordpress.org/WordPress_Nonces - but I doubt that this is related to that you work at midnight.

    kind regards,
    Kasia

  • Nithin

    Hi Mary,

    Hope you are doing good today. :slight_smile:

    Thank you for sharing the debug.log file, however I'm bit confused by the log, I suppose you had the log enabled for a while, as there are many fatal errors(not related to eNewsletter) starting from March 11 in the log. I guess they are already sorted, as your website seem to work fine.

    I have only focused at the logs from 18th, and only thing I could notice are some database error:

    [19-Mar-2017 17:46:09 America/Toronto] WordPress database error Table 'mary_wp.wp_enewsletter_send' doesn't exist for query DELETE A FROM bbvsf_enewsletter_send_members A INNER JOIN wp_enewsletter_send B ON A.send_id = B.send_id WHERE B.newsletter_id = 17 made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, Email_Newsletter->admin_init, Email_Newsletter->delete_newsletter
    
    [19-Mar-2017 17:51:48 America/Toronto] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE newsletter_id = 19 LIMIT 1' at line 1 for query UPDATE bbvsf_enewsletter_newsletters SET  WHERE newsletter_id = 19 LIMIT 1 made by do_action('wp_ajax_customize_save'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, WP_Customize_Manager->save, WP_Customize_Manager->save_changeset_post, wp_insert_post, wp_transition_post_status, do_action('transition_post_status'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, _wp_customize_publish_changeset, WP_Customize_Manager->_publish_changeset_values, do_action('customize_save'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, Email_Newsletter_Builder->save_builder

    Could you please check your database, and see whether the following listed tables exist in your system:

    wp_enewsletter_groups
    wp_enewsletter_members
    wp_enewsletter_member_group
    wp_enewsletter_meta
    wp_enewsletter_newsletters
    wp_enewsletter_send
    wp_enewsletter_send_members
    wp_enewsletter_settings

    In the above list, wp is the table prefix, and it will vary according to what you have configured as your databases table prefix. Could you please check, and let us know regarding this.

    Were you able to replicate the error message Cheatin' eh? Sorry, you are not allowed to customize this site., other than late night as you have mentioned? I checked this in your system, and I'm still not able to replicate. Are you able to notice this issue only during late nights?

    Please let us know how that goes, and provide more info, so that we could have a better idea. Have a nice day. :slight_smile:

    Best Regards,
    Nithin

  • Nithin

    Hi Mary,

    People seem to have the same problem with various plugins, so I think it is a WordPress issue. What do you think?

    We cannot rule out whether it's a plugin specific, or WordPress specific issue, unless we could replicate this in our system. I wasn't able to replicate this in my system, nor was able to notice the issue in your system, so it's pretty tough to state that it's a WordPress specific issue, because it works fine in our test.

    Since you aren't able to notice this issue again in your system, It might be more related to Nonces, or maybe a plugin conflict.

    Were you able to replicate the error message Cheatin' eh? Sorry, you are not allowed to customize this site., other than late night as you have mentioned? I checked this in your system, and I'm still not able to replicate. Are you able to notice this issue only during late nights?

    Or were you able to replicate this issue again? If yes, could you please fill us up with the above questions, so that it could have a better idea regarding whether it's related to Nonces, or something else.

    If you are able to replicate this issue again, could you please check whether a plugin conflict test helps in this case, please check the flowchart illustrated in getting support manual:
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let us know how that goes, have a nice day. :slight_smile:

    Best Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.